diff mbox series

[bug#67963,v2,17/37] gnu: Add perl-package-variant.

Message ID a343bf0c82f3de5b5723da6a7b2bc5371a7a3db1.1705443195.git.felix.lechner@lease-up.com
State New
Headers show
Series [bug#67963,v2,01/37] gnu: perl.scm: Fix indentation (no functional changes). | expand

Commit Message

Felix Lechner Jan. 16, 2024, 10:12 p.m. UTC
* gnu/packages/perl.scm (perl-package-variant): New variable.

Change-Id: Ia9a35b63a3e57e854455467730f31164504bb1f3
---
 gnu/packages/perl.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index dec4fca2bc..b510baccaa 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8753,6 +8753,38 @@  (define-public perl-package-stash-xs
 compiler.")
     (license (package-license perl))))
 
+(define-public perl-package-variant
+  (package
+    (name "perl-package-variant")
+    (version "1.003002")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/M/MS/MSTROUT/Package-Variant-" version
+             ".tar.gz"))
+       (sha256
+        (base32 "1p1n2ny5fb15bcbykyn523w6sv968gqs7nhjfm36dpac5yfq9vdj"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-test-fatal))
+    (propagated-inputs (list perl-import-into
+                             perl-module-runtime
+                             perl-strictures-2))
+    (home-page "https://metacpan.org/release/Package-Variant")
+    (synopsis "Parameterizable packages")
+    (description "This module allows you to build a variable package that
+contains a package template and can use it to build variant packages at
+runtime.
+
+Your variable package will export a subroutine which will build a variant
+package, combining its arguments with the template, and return the name
+of the new variant package.
+
+The implementation does not care about what kind of packages it builds,
+be they simple function exporters, classes, singletons or something
+entirely different.")
+    (license license:perl-license)))
+
 (define-public perl-padwalker
   (package
     (name "perl-padwalker")