diff mbox series

[bug#67963,v2,25/37] gnu: Add perl-text-xslate.

Message ID 260d60a9ce7fce9d9936536f83bdc111cf081766.1705443195.git.felix.lechner@lease-up.com
State New
Headers show
Series [bug#67963,v2,01/37] gnu: perl.scm: Fix indentation (no functional changes). | expand

Commit Message

Felix Lechner Jan. 16, 2024, 10:13 p.m. UTC
* gnu/packages/web.scm (perl-text-xslate): New variable.

Change-Id: Ib6e281402716e33bc6bf1e4a1ce8cf6772eda4ba
---
 gnu/packages/web.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 344a138961..27358e1269 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4650,6 +4650,32 @@  (define-public perl-test-www-mechanize-psgi
 applications.")
     (license license:perl-license)))
 
+(define-public perl-text-xslate
+  (package
+    (name "perl-text-xslate")
+    (version "3.5.9")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/S/SK/SKAJI/Text-Xslate-v"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "103lhyqqv53x9rqsnxcba3pc4qkbwnjsw3gpyd7rjm0aw65mrj20"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-file-copy-recursive
+                         perl-module-build
+                         perl-module-build-xsutil
+                         perl-test-requires))
+    (propagated-inputs (list perl-data-messagepack
+                             perl-mouse))
+    (home-page "https://metacpan.org/release/Text-Xslate")
+    (synopsis "Scalable template engine for Perl5")
+    (description "Xslate is a template engine, tuned for persistent
+applications, safe as an HTML generator, and with rich features.
+The philosophy of this module is sandboxing in the sense that the
+template logic should not have no access outside the template.")
+    (license license:perl-license)))
+
 (define-public perl-uri
   (package
     (name "perl-uri")