diff mbox series

[bug#67963,v2,14/37] gnu: Add perl-fcgi.

Message ID cf913953a20d1ffb255ae002c80fe2734d4ce962.1705443195.git.felix.lechner@lease-up.com
State New
Headers show
Series [bug#67963,v2,01/37] gnu: perl.scm: Fix indentation (no functional changes). | expand

Commit Message

Felix Lechner Jan. 16, 2024, 10:12 p.m. UTC
* gnu/packages/web.scm (perl-fcgi): New variable.

Change-Id: Ic57efb058ec0a2a46fca67ccf9b08806f21a46e1
---
 gnu/packages/web.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 08231347c2..344a138961 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3292,6 +3292,32 @@  (define-public perl-encode-locale
 with Encode::decode(locale => $string).")
     (home-page "https://metacpan.org/release/Encode-Locale")))
 
+(define-public perl-fcgi
+  (package
+    (name "perl-fcgi")
+    (version "0.82")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/FCGI-" version
+                           ".tar.gz"))
+       (sha256
+        (base32 "1kwyy08lc23yjwaj4m696cxjf195x4hm0d2fi82pzh52dpi60zac"))))
+    (build-system perl-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'configure 'provide-shell
+            (lambda _
+              (setenv "CONFIG_SHELL" (which "sh")))))))
+    (native-inputs (list bash
+                         perl-fcgi-client))
+    (home-page "https://metacpan.org/release/FCGI")
+    (synopsis "Fast CGI module")
+    (description "This is a FastCGI application library.")
+    (license (license:non-copyleft "file://LICENSE" "Open Market"))))
+
 (define-public perl-fcgi-client
   (package
     (name "perl-fcgi-client")