diff mbox series

[bug#67963,v2,07/37] gnu: Add perl-class-hash.

Message ID 91791905a9f28e2ac81ab89498a084517d288688.1705443194.git.felix.lechner@lease-up.com
State New
Headers show
Series [bug#67963,v2,01/37] gnu: perl.scm: Fix indentation (no functional changes). | expand

Commit Message

Felix Lechner Jan. 16, 2024, 10:12 p.m. UTC
* gnu/packages/perl.scm (perl-class-hash): New variable.

Change-Id: I8617698e0d40fb08fff23fdfb09ef24499de109e
---
 gnu/packages/perl.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 3f21c7e495..6314924868 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1617,6 +1617,27 @@  (define-public perl-class-factory-util
     (description "This module exports methods useful for factory classes.")
     (license (package-license perl))))
 
+(define-public perl-class-hash
+  (package
+    (name "perl-class-hash")
+    (version "1.01")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/H/HA/HANENKAMP/Class-Hash/Class-Hash-"
+             version ".tar.gz"))
+       (sha256
+        (base32 "1kcg00ks6vica496m6dqwb1c9gkb6igndkrxr4a7ff7391yg3ywz"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/release/Class-Hash")
+    (synopsis "Perl extension for hashes that look like classes")
+    (description "This component provides a method-based interface to a hash.
+Occasionally, it's more convenient to have named methods to access a hash
+than hash keys.  This module generalizes that behavior.  It tries to work
+the tied hash interface inside-out.")
+    (license license:perl-license)))
+
 (define-public perl-class-inspector
   (package
     (name "perl-class-inspector")