diff mbox series

[bug#67963,v2,28/37] gnu: Add perl-text-autoformat.

Message ID 2dd5c0b29c0a6ba26d76101b7f04a2a70ad4e9b7.1705443195.git.felix.lechner@lease-up.com
State New
Headers show
Series [bug#67963,v2,01/37] gnu: perl.scm: Fix indentation (no functional changes). | expand

Commit Message

Felix Lechner Jan. 16, 2024, 10:13 p.m. UTC
* gnu/packages/perl.scm (perl-text-autoformat): New variable.

Change-Id: I5158392b76c9946a3d972f5837d1e6ba6c622742
---
 gnu/packages/perl.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 921d8be1c2..22a240bf22 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -10946,6 +10946,27 @@  (define-public perl-text-aligner
 used to justify strings to various alignment styles.")
     (license license:x11)))
 
+(define-public perl-text-autoformat
+  (package
+    (name "perl-text-autoformat")
+    (version "1.75")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/N/NE/NEILB/Text-Autoformat-" version
+             ".tar.gz"))
+       (sha256
+        (base32 "0wdpqq1cds68i1clx2y22bnnm558d12sr7dmypdv9i5f7p7g9m4x"))))
+    (build-system perl-build-system)
+    (propagated-inputs (list perl-text-reform))
+    (home-page "https://metacpan.org/release/Text-Autoformat")
+    (synopsis "Automatic text wrapping and reformatting")
+    (description "The Text::Autoformat module provides a subroutine that
+wraps text to specified margins.  However, autoformat reformats its
+input by analysing the text's structure.")
+    (license license:perl-license)))
+
 (define-public perl-text-balanced
   (package
     (name "perl-text-balanced")