diff mbox series

[bug#67963,v2,29/37] gnu: Add perl-text-recordparser.

Message ID 2165f357c7e49e10c0068c81ffce4a1b1fe67612.1705443195.git.felix.lechner@lease-up.com
State New
Headers show
Series [bug#67963,v2,01/37] gnu: perl.scm: Fix indentation (no functional changes). | expand

Commit Message

Felix Lechner Jan. 16, 2024, 10:13 p.m. UTC
* gnu/packages/perl.scm (perl-text-recordparser): New variable.

Change-Id: I4316ca3a83e61c229be8f4cb022d4d6ee0848d5c
---
 gnu/packages/perl.scm | 50 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 22a240bf22..b205d77cfc 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -76,6 +76,7 @@  (define-module (gnu packages perl)
   #:use-module (gnu packages gd)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages gtk)
+  #:use-module (gnu packages graphviz)
   #:use-module (gnu packages image)
   #:use-module (gnu packages language)
   #:use-module (gnu packages less)
@@ -11262,6 +11263,55 @@  (define-public perl-text-patch
 by the standard @code{diff} utility.")
     (license license:gpl2+)))
 
+(define-public perl-text-recordparser
+  (package
+    (name "perl-text-recordparser")
+    (version "1.6.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/K/KC/KCLARK/Text-RecordParser-"
+             version ".tar.gz"))
+       (sha256
+        (base32 "0nn33c058bl957v38xhqig4ld34lifl4arqiilhxky339i0q2fys"))))
+    (build-system perl-build-system)
+    (arguments
+     (list
+      ;; #   Failed test 'Diagnostic OK'
+      ;; #   at t/13-tab2graph.t line 34.
+      ;; #          got: 'Fontconfig error: No writable cache directories
+      ;; # Fontconfig error: No writable cache directories
+      ;; # Image created "foo.png."
+      ;; # '
+      ;; #     expected: 'Image created "foo.png."
+      ;; # '
+      ;; # Looks like you failed 1 test of 4.
+      ;; t/13-tab2graph.t ....
+      ;; Dubious, test returned 1 (wstat 256, 0x100)
+      ;; Failed 1/4 subtests
+      #:tests? #f))
+    (native-inputs (list graphviz
+                         perl-module-install
+                         perl-test-exception))
+    (propagated-inputs (list perl-class-accessor
+                             perl-graphviz
+                             perl-io-stringy
+                             perl-list-moreutils
+                             perl-readonly
+                             perl-text-autoformat
+                             perl-text-tabulardisplay))
+    (home-page "https://metacpan.org/release/Text-RecordParser")
+    (synopsis "Parse record-oriented data in a text file")
+    (description "This module is for reading record-oriented data in a
+delimited text file.  The most common examples have records separated by
+newlines and fields separated by commas or tabs, but this module aims to
+provide a consistent interface for handling sequential records in a file
+however they are delimited.
+
+You can then use many methods to get to the data as arrays or hashes.")
+    (license license:gpl2)))
+
 (define-public perl-text-reform
   (package
     (name "perl-text-reform")