[bug#56701,13/19] gnu: python-oslo.context: Update to 5.0.0.
Commit Message
* gnu/packages/openstack.scm (python-oslo.context): Update to 5.0.0.
[native-inputs]: Remove python-bandit; add python-mypy.
[arguments]<phases>{relax-requirements}: Relax more requirements.
---
gnu/packages/openstack.scm | 14 ++++++++------
1 file changed, 8 insertions(+), 6 deletions(-)
Comments
On Fri, Jul 22, 2022 at 04:02:33PM +0200, Hartmut Goebel wrote:
> * gnu/packages/openstack.scm (python-oslo.context): Update to 5.0.0.
> [native-inputs]: Remove python-bandit; add python-mypy.
> [arguments]<phases>{relax-requirements}: Relax more requirements.
> ---
> gnu/packages/openstack.scm | 14 ++++++++------
> 1 file changed, 8 insertions(+), 6 deletions(-)
>
> diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
> index 08f6436af6..3f13b9613e 100644
> --- a/gnu/packages/openstack.scm
> +++ b/gnu/packages/openstack.scm
> @@ -522,30 +522,32 @@ common features used in Tempest.")
> (define-public python-oslo.context
> (package
> (name "python-oslo.context")
> - (version "3.1.1")
> + (version "5.0.0")
> (source
> (origin
> (method url-fetch)
> (uri (pypi-uri "oslo.context" version))
> (sha256
> (base32
> - "1l2z186rkd9acrb2ygf53yrdc1lgf7cy1akbhm21kgkzind4p2r6"))))
> + "091j2cjh1b60nx6s0a4amb2idh9awijnbmppc3an0738fv8cdh48"))))
> (build-system python-build-system)
> (arguments
> `(#:phases (modify-phases %standard-phases
> (add-after 'unpack 'relax-requirements
> (lambda _
> (substitute* "test-requirements.txt"
> - (("hacking>=3.0.1,<3.1.0")
> - "hacking>=3.0.1"))
> + (("hacking[<>!=].*") "hacking\n")
> + ;; unused, code-quality checks only
> + (("bandit[<>!=]" line) (string-append "# " line))
> + (("pre-commit[<>!=]" line) (string-append "# " line)))
> #t)))))
You can get rid of the trailing '#t' while applying the rest of the
patch.
> (propagated-inputs
> (list python-debtcollector))
> (native-inputs
> - (list python-bandit
> - python-coverage
> + (list python-coverage
> python-fixtures
> python-hacking
> + python-mypy
> python-oslotest
> python-pbr
> python-stestr))
> --
> 2.30.4
>
>
>
>
@@ -522,30 +522,32 @@ common features used in Tempest.")
(define-public python-oslo.context
(package
(name "python-oslo.context")
- (version "3.1.1")
+ (version "5.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "oslo.context" version))
(sha256
(base32
- "1l2z186rkd9acrb2ygf53yrdc1lgf7cy1akbhm21kgkzind4p2r6"))))
+ "091j2cjh1b60nx6s0a4amb2idh9awijnbmppc3an0738fv8cdh48"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
(add-after 'unpack 'relax-requirements
(lambda _
(substitute* "test-requirements.txt"
- (("hacking>=3.0.1,<3.1.0")
- "hacking>=3.0.1"))
+ (("hacking[<>!=].*") "hacking\n")
+ ;; unused, code-quality checks only
+ (("bandit[<>!=]" line) (string-append "# " line))
+ (("pre-commit[<>!=]" line) (string-append "# " line)))
#t)))))
(propagated-inputs
(list python-debtcollector))
(native-inputs
- (list python-bandit
- python-coverage
+ (list python-coverage
python-fixtures
python-hacking
+ python-mypy
python-oslotest
python-pbr
python-stestr))