diff mbox series

[bug#56701,05/19] gnu: Add python-os-service-types.

Message ID 7a4244c227f407e47c1f73d4750aae13a2787dec.1658498185.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Update python-pyjwt and its dependent packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 22, 2022, 2:02 p.m. UTC
* gnu/packages/openstack.scm (python-os-service-types): New variable.
---
 gnu/packages/openstack.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Efraim Flashner Aug. 4, 2022, 7:04 p.m. UTC | #1
On Fri, Jul 22, 2022 at 04:02:25PM +0200, Hartmut Goebel wrote:
> * gnu/packages/openstack.scm (python-os-service-types): New variable.
> ---
>  gnu/packages/openstack.scm | 28 ++++++++++++++++++++++++++++
>  1 file changed, 28 insertions(+)
> 
> diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
> index 0721d27dbf..a57210f847 100644
> --- a/gnu/packages/openstack.scm
> +++ b/gnu/packages/openstack.scm
> @@ -7,6 +7,7 @@
>  ;;; Copyright © 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
>  ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
>  ;;; Copyright © 2022 Tanguy Le Carrour <tanguy@bioneland.org>
> +;;; Copyright © 2022 Hartmut Goebel <h.goebel@crazy-compilers.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -251,6 +252,33 @@ to docs.openstack.org and developer.openstack.org.")
>    comprehensive manner.")
>      (license asl2.0)))
>  
> +(define-public python-os-service-types
> +  (package
> +    (name "python-os-service-types")
> +    (version "1.7.0")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "os-service-types" version))
> +              (sha256
> +               (base32
> +                "0v4chwr5jykkvkv4w7iaaic7gb06j6ziw7xrjlwkcf92m2ch501i"))))
> +    (build-system python-build-system)
> +    (arguments
> +     ;; The tests are disabled to avoid a circular dependency with
> +     ;; python-keystoneauth1.
> +     `(#:tests? #f))
> +    (native-inputs (list python-pbr))
> +    (home-page "https://docs.openstack.org/os-service-types/latest/")
> +    (synopsis "Python library for consuming OpenStack Service Types Authority
> +data")

The synopsis should be on one line, even if it needs to stretch into
that 80-90 character range. Or shorted slightly. You could probably drop
the "Python" part of the synopsis.

> +    (description "The @{OpenStack Service Types Authority} contains

You're missing something with the "@{", like @code{ or something.

> +information about official OpenStack services and their historical
> +service-type aliases.  The data is in JSON and the latest data should always
> +be used.  This simple library exists to allow for easy consumption of the
> +data, along with a built-in version of the data to use in case network access
> +is for some reason not possible and local caching of the fetched data.")
> +    (license asl2.0)))
> +
>  (define-public python-os-testr
>    (package
>      (name "python-os-testr")
> -- 
> 2.30.4
> 
> 
> 
>
diff mbox series

Patch

diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 0721d27dbf..a57210f847 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2022 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2022 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -251,6 +252,33 @@  to docs.openstack.org and developer.openstack.org.")
   comprehensive manner.")
     (license asl2.0)))
 
+(define-public python-os-service-types
+  (package
+    (name "python-os-service-types")
+    (version "1.7.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "os-service-types" version))
+              (sha256
+               (base32
+                "0v4chwr5jykkvkv4w7iaaic7gb06j6ziw7xrjlwkcf92m2ch501i"))))
+    (build-system python-build-system)
+    (arguments
+     ;; The tests are disabled to avoid a circular dependency with
+     ;; python-keystoneauth1.
+     `(#:tests? #f))
+    (native-inputs (list python-pbr))
+    (home-page "https://docs.openstack.org/os-service-types/latest/")
+    (synopsis "Python library for consuming OpenStack Service Types Authority
+data")
+    (description "The @{OpenStack Service Types Authority} contains
+information about official OpenStack services and their historical
+service-type aliases.  The data is in JSON and the latest data should always
+be used.  This simple library exists to allow for easy consumption of the
+data, along with a built-in version of the data to use in case network access
+is for some reason not possible and local caching of the fetched data.")
+    (license asl2.0)))
+
 (define-public python-os-testr
   (package
     (name "python-os-testr")