diff mbox series

[bug#56701,03/19] gnu: Add python-dogpile.cache.

Message ID c319ed18e80f9863bf1ec67b669beb68b1fa314a.1658498185.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Update python-pyjwt and its dependent packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 22, 2022, 2:02 p.m. UTC
* gnu/packages/databases.scm (python-dogpile.cache): New variable.
---
 gnu/packages/databases.scm | 31 ++++++++++++++++++++++++++++++-
 1 file changed, 30 insertions(+), 1 deletion(-)

Comments

Efraim Flashner Aug. 4, 2022, 7:04 p.m. UTC | #1
On Fri, Jul 22, 2022 at 04:02:23PM +0200, Hartmut Goebel wrote:
> * gnu/packages/databases.scm (python-dogpile.cache): New variable.
> ---
>  gnu/packages/databases.scm | 31 ++++++++++++++++++++++++++++++-
>  1 file changed, 30 insertions(+), 1 deletion(-)
> 
> diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
> index 32c36fe337..0bdcee5f7c 100644
> --- a/gnu/packages/databases.scm
> +++ b/gnu/packages/databases.scm
> @@ -8,7 +8,7 @@
>  ;;; Copyright © 2015, 2016 Sou Bunnbu <iyzsong@gmail.com>
>  ;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
>  ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
> -;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
> +;;; Copyright © 2016, 2022 Hartmut Goebel <h.goebel@crazy-compilers.com>
>  ;;; Copyright © 2016 Christine Lemmer-Webber <cwebber@dustycloud.org>
>  ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
>  ;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
> @@ -122,6 +122,7 @@
>    #:use-module (gnu packages ncurses)
>    #:use-module (gnu packages networking)
>    #:use-module (gnu packages onc-rpc)
> +  #:use-module (gnu packages openstack)
>    #:use-module (gnu packages pantheon)
>    #:use-module (gnu packages parallel)
>    #:use-module (gnu packages pcre)
> @@ -4823,3 +4824,31 @@ create design, and edit database file compatible with SQLite.")
>      (description
>       "This package implements the @acronym{LSP, Language Server Protocol} for SQL.")
>      (license license:expat)))
> +

I don't like the "." in the package name, but its still allowed.

> +(define-public python-dogpile.cache
> +  (package
> +    (name "python-dogpile.cache")
> +    (version "1.1.8")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "dogpile.cache" version))
> +              (sha256
> +               (base32
> +                "0kpx42vxzss4sz5ic6mp01a97zinzm6q76n8li2gbi4ccfxyhi6q"))))
> +    (build-system python-build-system)
> +    (arguments
> +     '(#:phases
> +       (modify-phases %standard-phases
> +         (replace 'check
> +           (lambda* (#:key tests? #:allow-other-keys)
> +             (when tests?
> +               (invoke "pytest" )))))))

This extra space though, after pytest, it needs to go :)

> +    (native-inputs (list python-mako python-pytest))
> +    (propagated-inputs (list python-decorator python-stevedore))
> +    (home-page "https://github.com/sqlalchemy/dogpile.cache")
> +    (synopsis "Caching front-end based on the Dogpile lock")
> +    (description "@code{dogpile.cache} is a caching API which provides a
> +generic interface to caching backends of any variety, and additionally
> +provides API hooks which integrate these cache backends with the locking
> +mechanism of @code{dogpile}.")
> +    (license license:expat)))
> -- 
> 2.30.4
> 
> 
> 
>
\( Aug. 4, 2022, 7:07 p.m. UTC | #2
On Thu Aug 4, 2022 at 8:04 PM BST, Efraim Flashner wrote:
> I don't like the "." in the package name, but its still allowed.
Is it? I've never seen a package with a period in the name. It
should probably be converted to a hyphen: python-dogpile-cache.

    -- (
Efraim Flashner Aug. 4, 2022, 8:22 p.m. UTC | #3
On Thu, Aug 04, 2022 at 08:07:33PM +0100, ( wrote:
> On Thu Aug 4, 2022 at 8:04 PM BST, Efraim Flashner wrote:
> > I don't like the "." in the package name, but its still allowed.
> Is it? I've never seen a package with a period in the name. It
> should probably be converted to a hyphen: python-dogpile-cache.
> 

'guix package -A \\. | cut -f1 | grep -v [[:digit:]]\.[[:digit:]] | wc -l'
reports there are 54 packages with a period in their name. That
eliminates packages like guile2.2-* or ocaml4.07-*.
\( Aug. 4, 2022, 8:26 p.m. UTC | #4
On Thu Aug 4, 2022 at 9:22 PM BST, Efraim Flashner wrote:
> 'guix package -A \\. | cut -f1 | grep -v [[:digit:]]\.[[:digit:]] | wc -l'
> reports there are 54 packages with a period in their name. That
> eliminates packages like guile2.2-* or ocaml4.07-*.
Ah, yes, you're right.

    -- (
Hartmut Goebel Aug. 4, 2022, 8:33 p.m. UTC | #5
Am 04.08.22 um 21:04 schrieb Efraim Flashner:
> I don't like the "." in the package name, but its still allowed.

Yes, I stumbled over this, too. And decided to keep it for two reasons:

1) This is the name the pypi importer created

2) There is another dogpile.* package using the same naming conventions.

Beside this I have no actual opinion and it would be fine for me to 
change the dot into a dash (and eventually deprecating the other 
dogpile.* packages, too)
Efraim Flashner Aug. 4, 2022, 9:35 p.m. UTC | #6
On Thu, Aug 04, 2022 at 10:33:46PM +0200, Hartmut Goebel wrote:
> Am 04.08.22 um 21:04 schrieb Efraim Flashner:
> > I don't like the "." in the package name, but its still allowed.
> 
> Yes, I stumbled over this, too. And decided to keep it for two reasons:
> 
> 1) This is the name the pypi importer created
> 
> 2) There is another dogpile.* package using the same naming conventions.
> 
> Beside this I have no actual opinion and it would be fine for me to change
> the dot into a dash (and eventually deprecating the other dogpile.*
> packages, too)
> 

Let's leave it as the importer created it for now.
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 32c36fe337..0bdcee5f7c 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -8,7 +8,7 @@ 
 ;;; Copyright © 2015, 2016 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
-;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2016, 2022 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2016 Christine Lemmer-Webber <cwebber@dustycloud.org>
 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
@@ -122,6 +122,7 @@ 
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages networking)
   #:use-module (gnu packages onc-rpc)
+  #:use-module (gnu packages openstack)
   #:use-module (gnu packages pantheon)
   #:use-module (gnu packages parallel)
   #:use-module (gnu packages pcre)
@@ -4823,3 +4824,31 @@  create design, and edit database file compatible with SQLite.")
     (description
      "This package implements the @acronym{LSP, Language Server Protocol} for SQL.")
     (license license:expat)))
+
+(define-public python-dogpile.cache
+  (package
+    (name "python-dogpile.cache")
+    (version "1.1.8")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "dogpile.cache" version))
+              (sha256
+               (base32
+                "0kpx42vxzss4sz5ic6mp01a97zinzm6q76n8li2gbi4ccfxyhi6q"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "pytest" )))))))
+    (native-inputs (list python-mako python-pytest))
+    (propagated-inputs (list python-decorator python-stevedore))
+    (home-page "https://github.com/sqlalchemy/dogpile.cache")
+    (synopsis "Caching front-end based on the Dogpile lock")
+    (description "@code{dogpile.cache} is a caching API which provides a
+generic interface to caching backends of any variety, and additionally
+provides API hooks which integrate these cache backends with the locking
+mechanism of @code{dogpile}.")
+    (license license:expat)))