diff mbox series

[bug#56701,06/19] gnu: Add python-oslo.concurrency.

Message ID b57722fe76a2cf9a88d29a4ce1c06f45e6785e0f.1658498185.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Update python-pyjwt and its dependent packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 22, 2022, 2:02 p.m. UTC
* gnu/packages/openstack.scm (python-oslo.concurrency): New variable.
---
 gnu/packages/openstack.scm | 42 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)

Comments

Efraim Flashner Aug. 4, 2022, 7:04 p.m. UTC | #1
On Fri, Jul 22, 2022 at 04:02:26PM +0200, Hartmut Goebel wrote:
> * gnu/packages/openstack.scm (python-oslo.concurrency): New variable.
> ---
>  gnu/packages/openstack.scm | 42 ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 42 insertions(+)
> 
> diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
> index a57210f847..7b0c96d11c 100644
> --- a/gnu/packages/openstack.scm
> +++ b/gnu/packages/openstack.scm
> @@ -389,6 +389,48 @@ common features used in Tempest.")
>  ;;; Packages from the Oslo library
>  ;;;
>  
> +(define-public python-oslo.concurrency
> +  (package
> +    (name "python-oslo.concurrency")
> +    (version "4.5.1")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "oslo.concurrency" version))
> +              (sha256
> +               (base32
> +                "05ysy2jnxb7l2prw38kys0afr99mzh3bw5nd42zvm59xp53bjsb8"))))
> +    (build-system python-build-system)
> +    (arguments
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         (add-after 'unpack 'relax-requirements
> +           (lambda _
> +             (substitute* "test-requirements.txt"
> +               (("hacking[<>!=]" line) (string-append "# " line))
> +               (("coverage[<>!=]" line) (string-append "# " line))
> +               (("bandit[<>!=]" line) (string-append "# " line))
> +               (("pre-commit[<>!=]" line) (string-append "# " line)))))
> +         (add-before 'check 'fix-tests
> +           (lambda _
> +             (substitute* "oslo_concurrency/tests/unit/test_processutils.py"
> +               (("#!/bin/bash") (string-append "#!" (which "bash")))
> +               (("#!/bin/sh") (string-append "#!" (which "sh")))
> +               (("'/usr/bin/env'") (string-append "'" (which "env") "'"))
> +               (("'/usr/bin/env ") (string-append "'" (which "env") " "))
> +               (("'/bin/true'") (string-append "'" (which "true") "'"))))))))
> +    (native-inputs (list python-pbr
> +                         ;; for tests:
> +                         python-oslotest
> +                         python-fixtures
> +                         python-stestr
> +                         python-eventlet))
> +    (propagated-inputs (list python-fasteners python-oslo.config
> +                             python-oslo.i18n python-oslo.utils))
> +    (home-page "https://docs.openstack.org/oslo.concurrency/latest/")
> +    (synopsis "Oslo Concurrency library")
> +    (description "Oslo Concurrency library")

The description needs to be fleshed out some more.

> +    (license asl2.0)))
> +
>  (define-public python-oslo.config
>    (package
>      (name "python-oslo.config")
> -- 
> 2.30.4
> 
> 
> 
>
diff mbox series

Patch

diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index a57210f847..7b0c96d11c 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -389,6 +389,48 @@  common features used in Tempest.")
 ;;; Packages from the Oslo library
 ;;;
 
+(define-public python-oslo.concurrency
+  (package
+    (name "python-oslo.concurrency")
+    (version "4.5.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "oslo.concurrency" version))
+              (sha256
+               (base32
+                "05ysy2jnxb7l2prw38kys0afr99mzh3bw5nd42zvm59xp53bjsb8"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'relax-requirements
+           (lambda _
+             (substitute* "test-requirements.txt"
+               (("hacking[<>!=]" line) (string-append "# " line))
+               (("coverage[<>!=]" line) (string-append "# " line))
+               (("bandit[<>!=]" line) (string-append "# " line))
+               (("pre-commit[<>!=]" line) (string-append "# " line)))))
+         (add-before 'check 'fix-tests
+           (lambda _
+             (substitute* "oslo_concurrency/tests/unit/test_processutils.py"
+               (("#!/bin/bash") (string-append "#!" (which "bash")))
+               (("#!/bin/sh") (string-append "#!" (which "sh")))
+               (("'/usr/bin/env'") (string-append "'" (which "env") "'"))
+               (("'/usr/bin/env ") (string-append "'" (which "env") " "))
+               (("'/bin/true'") (string-append "'" (which "true") "'"))))))))
+    (native-inputs (list python-pbr
+                         ;; for tests:
+                         python-oslotest
+                         python-fixtures
+                         python-stestr
+                         python-eventlet))
+    (propagated-inputs (list python-fasteners python-oslo.config
+                             python-oslo.i18n python-oslo.utils))
+    (home-page "https://docs.openstack.org/oslo.concurrency/latest/")
+    (synopsis "Oslo Concurrency library")
+    (description "Oslo Concurrency library")
+    (license asl2.0)))
+
 (define-public python-oslo.config
   (package
     (name "python-oslo.config")