diff mbox series

[bug#56701,04/19] gnu: Add python-statsd.

Message ID 46ef1bcf8d694551cac0a82828b3d55cbc442939.1658498185.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Update python-pyjwt and its dependent packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 22, 2022, 2:02 p.m. UTC
* gnu/packages/monitoring.scm (python-statsd): New variable.
---
 gnu/packages/monitoring.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index 1544efb614..2412dba774 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -10,6 +10,7 @@ 
 ;;; Copyright © 2021, 2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
+;;; Copyright © 2022 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -682,3 +683,21 @@  processes which keep waking up the disk unnecessarily and thus prevent some
 power saving.")
     (home-page "https://github.com/martinpitt/fatrace")
     (license license:gpl3+)))
+
+(define-public python-statsd
+  (package
+    (name "python-statsd")
+    (version "3.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "statsd" version))
+              (sha256
+               (base32
+                "07yxnlalvcglgwa9pjs1clwrmwx7a4575jai7q05jz3g4i6dprp3"))))
+    (build-system python-build-system)
+    (native-inputs (list python-mock python-nose))
+    (home-page "https://github.com/jsocol/pystatsd")
+    (synopsis "Simple StatsD client")
+    (description "StatsD is a friendly front-end to Graphite.  This package
+provides a simple Python client for the StatsD daemon.")
+    (license license:expat)))