diff mbox series

[bug#56701,16/19] gnu: python-pyjwt: Update to 2.4.0.

Message ID 00605bc1bf4040c82f9668f7ce8c521070178982.1658498185.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Update python-pyjwt and its dependent packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 22, 2022, 2:02 p.m. UTC
* gnu/packages/python-xyz.scm (python-pyjwt): Update to 2.4.0.
  [source]: Remove snippet.
  [arguments]<phases>{check}: Remove now unused parts, honor '#:tests?'.
  (native-inputs]: Remove python-pytest-cov, add python-cryptography.
---
 gnu/packages/python-xyz.scm | 23 ++++++-----------------
 1 file changed, 6 insertions(+), 17 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 284729e834..de2a4d6ffb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3736,34 +3736,23 @@  memory usage and transliteration quality.")
 (define-public python-pyjwt
   (package
     (name "python-pyjwt")
-    (version "1.7.1")
+    (version "2.4.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "PyJWT" version))
        (sha256
         (base32
-         "15hflax5qkw1v6nssk1r0wkj83jgghskcmn875m3wgvpzdvajncd"))
-       (modules '((guix build utils)))
-       (snippet
-        '(begin
-           (for-each delete-file-recursively
-                     (find-files "." "\\.pyc$"))
-           #t))))
+         "1fmbcwfw1463wjzwbcgg3s16rad6kfb1mc5y7jbkp6v9ihh0hafl"))))
     (build-system python-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
                   (replace 'check
-                    (lambda _
-                      ;; Mimic upstream commit 3a20892442b34c7 to get
-                      ;; rid of dependency on pytest-runner < 5.0.
-                      ;; Remove substitution for PyJWT > 1.7.1.
-                      (substitute* "setup.py"
-                        ((".*pytest-runner.*")
-                         ""))
-                      (invoke "pytest" "-vv"))))))
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (when tests?
+                        (invoke "pytest" "-vv")))))))
     (native-inputs
-     (list python-pytest python-pytest-cov))
+     (list python-cryptography python-pytest))
     (home-page "https://github.com/progrium/pyjwt")
     (synopsis "JSON Web Token implementation in Python")
     (description