diff mbox series

[bug#56701,08/19] gnu: Add python-requestsexceptions.

Message ID dd8398c899847634f2fc388ab1fc1316832c68d4.1658498185.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Update python-pyjwt and its dependent packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 22, 2022, 2:02 p.m. UTC
* gnu/packages/openstack.scm (python-requestsexceptions): New variable.
---
 gnu/packages/openstack.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Efraim Flashner Aug. 4, 2022, 7:01 p.m. UTC | #1
On Fri, Jul 22, 2022 at 04:02:28PM +0200, Hartmut Goebel wrote:
> * gnu/packages/openstack.scm (python-requestsexceptions): New variable.
> ---
>  gnu/packages/openstack.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)
> 
> diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
> index b791c1c076..3594179780 100644
> --- a/gnu/packages/openstack.scm
> +++ b/gnu/packages/openstack.scm
> @@ -923,3 +923,28 @@ permanence.")
>       "Git-review is a command-line tool that helps submitting Git branches to
>  Gerrit for review, or fetching existing ones.")
>      (license asl2.0)))
> +
> +(define-public python-requestsexceptions
> +  (package
> +    (name "python-requestsexceptions")
> +    (version "1.4.0")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "requestsexceptions" version))
> +              (sha256
> +               (base32
> +                "0r9hp9yzgj8r81q5gc6r8sgxldqc09xi6ax0b7a6dw0qfv3wp5dh"))))
> +    (build-system python-build-system)
> +    (arguments
> +     '(#:tests? #f))  ; no tests
> +    (native-inputs (list python-pbr))
> +    (home-page "https://www.openstack.org/")
> +    (synopsis "Import exceptions from potentially bundled packages in
> +requests")

Synopsis should be one line.

> +    (description "The Python requests library bundles the urllib3 library,
> +however, some software distributions modify requests to remove the bundled
> +library.  This makes some operations difficult, such as suppressing the
> +“insecure platform warning” messages that urllib emits.  This package is a
> +simple library to find the correct path to exceptions in the requests library
> +regardless of whether they are bundled or not.")
> +    (license asl2.0)))
> -- 
> 2.30.4
> 
> 
> 
>
diff mbox series

Patch

diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index b791c1c076..3594179780 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -923,3 +923,28 @@  permanence.")
      "Git-review is a command-line tool that helps submitting Git branches to
 Gerrit for review, or fetching existing ones.")
     (license asl2.0)))
+
+(define-public python-requestsexceptions
+  (package
+    (name "python-requestsexceptions")
+    (version "1.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "requestsexceptions" version))
+              (sha256
+               (base32
+                "0r9hp9yzgj8r81q5gc6r8sgxldqc09xi6ax0b7a6dw0qfv3wp5dh"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:tests? #f))  ; no tests
+    (native-inputs (list python-pbr))
+    (home-page "https://www.openstack.org/")
+    (synopsis "Import exceptions from potentially bundled packages in
+requests")
+    (description "The Python requests library bundles the urllib3 library,
+however, some software distributions modify requests to remove the bundled
+library.  This makes some operations difficult, such as suppressing the
+“insecure platform warning” messages that urllib emits.  This package is a
+simple library to find the correct path to exceptions in the requests library
+regardless of whether they are bundled or not.")
+    (license asl2.0)))