diff mbox series

[bug#56701,12/19] gnu: python-munch: Update to 2.5.0.

Message ID 1af031f12a34996ea4d7ab5b0db439259a0c725d.1658498185.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Update python-pyjwt and its dependent packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 22, 2022, 2:02 p.m. UTC
* gnu/packages/python-xyz.scm (python-munch): Update to 2.5.0.
  [propagated-inputs]: Add python-six.
  [native-inputs]: Add python-pbr and python-pytest.
---
 gnu/packages/python-xyz.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9e6e38532b..284729e834 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5715,15 +5715,17 @@  the Texinfo, HTML, and PDF formats.")))
 (define-public python-munch
   (package
     (name "python-munch")
-    (version "2.0.4")
+    (version "2.5.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "munch" version))
         (sha256
          (base32
-          "1cmqg91xnqx8gvnh4pmp0bfl1dfcm65d5p9mg73zz8pkjhx6h80l"))))
+          "1lnvlic9g68hcmgdnv5bzp0nx2bf1kjclj54gx0s7nyl4ipmywrd"))))
     (build-system python-build-system)
+    (native-inputs (list python-pbr python-pytest))
+    (propagated-inputs (list python-six))
     (home-page "https://github.com/Infinidat/munch")
     (synopsis "Dot-accessible dictionary")
     (description "Munch is a dot-accessible dictionary similar to JavaScript