diff mbox series

[bug#56701,01/19] gnu: python-args: Make it build with Python 3.

Message ID 1f84612facf1468febbf17587a8f10db1b0874f3.1658498185.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Update python-pyjwt and its dependent packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 22, 2022, 2:02 p.m. UTC
This package is unmaintained, but still used.  Patch the contained
Python-2-code to make it build with Python 3.

* gnu/packages/python-xyz.scm (python-args)[arguments]: Add phase
  patch-python2-code.
---
 gnu/packages/python-xyz.scm | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

Comments

Efraim Flashner Aug. 4, 2022, 7:04 p.m. UTC | #1
On Fri, Jul 22, 2022 at 04:02:21PM +0200, Hartmut Goebel wrote:
> This package is unmaintained, but still used.  Patch the contained
> Python-2-code to make it build with Python 3.
> 

This one doesn't seem to be needed anymore.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7f6bbd55be..9e6e38532b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19,7 +19,7 @@ 
 ;;; Copyright © 2015, 2016 Chris Marusich <cmmarusich@gmail.com>
 ;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
 ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
-;;; Copyright © 2016, 2018, 2019, 2021 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2016, 2018, 2019, 2021, 2022 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2016 Daniel Pimentel <d4n1@d4n1.org>
 ;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2016, 2017 Troy Sankey <sankeytms@gmail.com>
@@ -14071,6 +14071,14 @@  files for use with Python.")
                (base32
                 "057qzi46h5dmxdqknsbrssn78lmqjlnm624iqdhrnpk26zcbi1d7"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-python2-code
+           (lambda _
+             (substitute* "args.py"
+               (("isinstance\\(obj, basestring\\)")
+                "isinstance(obj, str)")))))))
     (home-page "https://github.com/kennethreitz/args")
     (synopsis "Command-line argument parser")
     (description