diff mbox series

[bug#56701,18/19] gnu: python-pygithub: Update to 1.55.

Message ID b63ce74d71eb965dd468c4544422cae29e36db1c.1658498185.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Update python-pyjwt and its dependent packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 22, 2022, 2:02 p.m. UTC
* gnu/packages/python-xyz.scm (python-pygithub): Update to 1.55.
  [propagated-inputs]: Add python-pynacl.
---
 gnu/packages/python-xyz.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index de2a4d6ffb..4494735c97 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4562,7 +4562,7 @@  to deprecate classes, functions or methods.")
 (define-public python-pygithub
   (package
     (name "python-pygithub")
-    (version "1.54.1")
+    (version "1.55")
     (source
      ;; We fetch from the Git repo because there are no tests in the PyPI
      ;; archive.
@@ -4573,7 +4573,7 @@  to deprecate classes, functions or methods.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1nl74bp5ikdnrc8xq0qr25ryl1mvarf0xi43k8w5jzlrllhq0nkq"))))
+        (base32 "082bxffpy4h97dsay3l75cpgfjj10kywkvicnm6xscwvah285q9y"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -4585,7 +4585,7 @@  to deprecate classes, functions or methods.")
              #t)))))
     (propagated-inputs
      (list python-cryptography python-deprecated python-pyjwt
-           python-requests))
+           python-pynacl python-requests))
     (native-inputs
      (list python-httpretty python-pytest))
     (home-page "https://pygithub.readthedocs.io/en/latest/")