diff mbox series

[bug#56701,11/19] gnu: python-keystoneclient: Update to 5.0.0.

Message ID 4fef2f3fb7039d66382e710e2a4d0d08a20d27aa.1658498185.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Update python-pyjwt and its dependent packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel July 22, 2022, 2:02 p.m. UTC
* gnu/packages/openstack.scm (python-keystoneclient): Update to 5.0.0.
  [arguments]<phases>{relax-requirements}: New phase.
  [propagated-inputs]: Remove python-pbr; add python-keystoneauth1.
  [native-inputs]: Adjust to new style. Remove python-sphinx, python-coverage,
  python-discover, python-hacking, python-mox3, python-oslosphinx,
  python-pycrypto, python-testrepository, and python-webob; add python-pbr,
  python-stestr, and python-testscenarios.
---
 gnu/packages/openstack.scm | 55 +++++++++++++++++++++-----------------
 1 file changed, 30 insertions(+), 25 deletions(-)

Comments

Efraim Flashner Aug. 4, 2022, 7:04 p.m. UTC | #1
On Fri, Jul 22, 2022 at 04:02:31PM +0200, Hartmut Goebel wrote:
> * gnu/packages/openstack.scm (python-keystoneclient): Update to 5.0.0.
>   [arguments]<phases>{relax-requirements}: New phase.
>   [propagated-inputs]: Remove python-pbr; add python-keystoneauth1.
>   [native-inputs]: Adjust to new style. Remove python-sphinx, python-coverage,
>   python-discover, python-hacking, python-mox3, python-oslosphinx,
>   python-pycrypto, python-testrepository, and python-webob; add python-pbr,
>   python-stestr, and python-testscenarios.
> ---
>  gnu/packages/openstack.scm | 55 +++++++++++++++++++++-----------------
>  1 file changed, 30 insertions(+), 25 deletions(-)
> 
> diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
> index d09de5e441..08f6436af6 100644
> --- a/gnu/packages/openstack.scm
> +++ b/gnu/packages/openstack.scm
> @@ -847,49 +847,54 @@ process of writing new clients.")
>  (define-public python-keystoneclient
>    (package
>      (name "python-keystoneclient")
> -    (version "1.8.1")
> +    (version "5.0.0")
>      (source
>        (origin
>          (method url-fetch)
>          (uri (pypi-uri "python-keystoneclient" version))
>          (sha256
>           (base32
> -          "1w4csvkah67rfpxylxnvs2s3594i0f9isy8pf4gnsqs5zirvjaa4"))))
> +          "0gza5fx3xl3l6vrc6pnhbzhipz1fz9h98kwxqp7mmd90pwrxll0g"))))
>      (build-system python-build-system)
>      (arguments
> -     '(#:tests? #f)) ; FIXME: Many tests are failing.
> +     '(#:tests? #f   ; FIXME: Many tests are failing.
> +       #:phases (modify-phases %standard-phases
> +                  (add-after 'unpack 'relax-requirements
> +                    (lambda _
> +                      (substitute* "test-requirements.txt"
> +                        ;; unused, code-quality checks only
> +                        (("hacking[<>!=]" line) (string-append "# " line))
> +                        (("flake8-.*[<>!=]" line) (string-append "# " line))
> +                        (("pycodestyle[<>!=]" line) (string-append "# " line))
> +                        (("bandit[<>!=]" line) (string-append "# " line))
> +                        (("coverage[<>!=]" line) (string-append "# " line))
> +                        (("reno[<>!=]" line) (string-append "# " line))
> +                      ))))))

These close parentheses should be on the previous line.

>      (native-inputs
> -     `(("python-sphinx" ,python-sphinx)
> -       ;; and some packages for the tests
> -       ("openssl" ,openssl)
> -       ("python-coverage" ,python-coverage)
> -       ("python-discover" ,python-discover)
> -       ("python-fixtures" ,python-fixtures)
> -       ("python-hacking" ,python-hacking)
> -       ("python-keyring" ,python-keyring)
> -       ("python-lxml" ,python-lxml)
> -       ("python-mock" ,python-mock)
> -       ("python-mox3" ,python-mox3)
> -       ("python-oauthlib" ,python-oauthlib)
> -       ("python-oslosphinx" ,python-oslosphinx)
> -       ("python-oslotest" ,python-oslotest)
> -       ("python-pycrypto" ,python-pycrypto)
> -       ("python-requests-mock" ,python-requests-mock)
> -       ("python-temptest-lib" ,python-tempest-lib)
> -       ("python-testrepository" ,python-testrepository)
> -       ("python-testresources" ,python-testresources)
> -       ("python-testtools" ,python-testtools)
> -       ("python-webob" ,python-webob)))
> +     (list openssl
> +           python-fixtures
> +           python-keyring
> +           python-lxml
> +           python-mock
> +           python-oauthlib
> +           python-oslotest
> +           python-pbr
> +           python-requests-mock
> +           python-stestr
> +           python-tempest-lib
> +           python-testresources
> +           python-testscenarios
> +           python-testtools))
>      (propagated-inputs
>       (list python-babel
>             python-debtcollector
>             python-iso8601
> +           python-keystoneauth1
>             python-netaddr
>             python-oslo.config
>             python-oslo.i18n
>             python-oslo.serialization
>             python-oslo.utils
> -           python-pbr
>             python-prettytable
>             python-requests
>             python-six
> -- 
> 2.30.4
> 
> 
> 
>
diff mbox series

Patch

diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index d09de5e441..08f6436af6 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -847,49 +847,54 @@  process of writing new clients.")
 (define-public python-keystoneclient
   (package
     (name "python-keystoneclient")
-    (version "1.8.1")
+    (version "5.0.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "python-keystoneclient" version))
         (sha256
          (base32
-          "1w4csvkah67rfpxylxnvs2s3594i0f9isy8pf4gnsqs5zirvjaa4"))))
+          "0gza5fx3xl3l6vrc6pnhbzhipz1fz9h98kwxqp7mmd90pwrxll0g"))))
     (build-system python-build-system)
     (arguments
-     '(#:tests? #f)) ; FIXME: Many tests are failing.
+     '(#:tests? #f   ; FIXME: Many tests are failing.
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'relax-requirements
+                    (lambda _
+                      (substitute* "test-requirements.txt"
+                        ;; unused, code-quality checks only
+                        (("hacking[<>!=]" line) (string-append "# " line))
+                        (("flake8-.*[<>!=]" line) (string-append "# " line))
+                        (("pycodestyle[<>!=]" line) (string-append "# " line))
+                        (("bandit[<>!=]" line) (string-append "# " line))
+                        (("coverage[<>!=]" line) (string-append "# " line))
+                        (("reno[<>!=]" line) (string-append "# " line))
+                      ))))))
     (native-inputs
-     `(("python-sphinx" ,python-sphinx)
-       ;; and some packages for the tests
-       ("openssl" ,openssl)
-       ("python-coverage" ,python-coverage)
-       ("python-discover" ,python-discover)
-       ("python-fixtures" ,python-fixtures)
-       ("python-hacking" ,python-hacking)
-       ("python-keyring" ,python-keyring)
-       ("python-lxml" ,python-lxml)
-       ("python-mock" ,python-mock)
-       ("python-mox3" ,python-mox3)
-       ("python-oauthlib" ,python-oauthlib)
-       ("python-oslosphinx" ,python-oslosphinx)
-       ("python-oslotest" ,python-oslotest)
-       ("python-pycrypto" ,python-pycrypto)
-       ("python-requests-mock" ,python-requests-mock)
-       ("python-temptest-lib" ,python-tempest-lib)
-       ("python-testrepository" ,python-testrepository)
-       ("python-testresources" ,python-testresources)
-       ("python-testtools" ,python-testtools)
-       ("python-webob" ,python-webob)))
+     (list openssl
+           python-fixtures
+           python-keyring
+           python-lxml
+           python-mock
+           python-oauthlib
+           python-oslotest
+           python-pbr
+           python-requests-mock
+           python-stestr
+           python-tempest-lib
+           python-testresources
+           python-testscenarios
+           python-testtools))
     (propagated-inputs
      (list python-babel
            python-debtcollector
            python-iso8601
+           python-keystoneauth1
            python-netaddr
            python-oslo.config
            python-oslo.i18n
            python-oslo.serialization
            python-oslo.utils
-           python-pbr
            python-prettytable
            python-requests
            python-six