diff mbox series

[bug#66801,v3,05/15] gnu: Add elixir-makeup.

Message ID f5a6ac8077a3cfb83a59c747da29a5299a982c44.1702044562.git.contact@phfrohring.com
State New
Headers show
Series [bug#66801,v3,01/15] build-system: Add mix-build-system. | expand

Commit Message

Pierre-Henry Fröhring Dec. 8, 2023, 3:03 p.m. UTC
From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>

* gnu/packages/elixir-xyz.scm (elixir-makeup): New variable.

Change-Id: I21fe9ffddb4c95a2c67b74340b1105c2a54d3c82
---
 gnu/packages/elixir-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Liliana Marie Prikler Dec. 8, 2023, 3:30 p.m. UTC | #1
Am Freitag, dem 08.12.2023 um 16:03 +0100 schrieb Pierre-Henry
Fröhring:
> From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>
> 
> * gnu/packages/elixir-xyz.scm (elixir-makeup): New variable.
> 
> Change-Id: I21fe9ffddb4c95a2c67b74340b1105c2a54d3c82
> ---
>  gnu/packages/elixir-xyz.scm | 22 ++++++++++++++++++++++
>  1 file changed, 22 insertions(+)
> 
> diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-
> xyz.scm
> index 352360fae..afc8b0db0 100644
> --- a/gnu/packages/elixir-xyz.scm
> +++ b/gnu/packages/elixir-xyz.scm
> @@ -52,6 +52,28 @@ (define-public elixir-nimble-parsec
>      (home-page "https://hexdocs.pm/nimble_parsec/")
>      (license license:asl2.0)))
>  
> +(define-public elixir-makeup
> +  (package
> +    (name "elixir-makeup")
> +    (version "1.1.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (hexpm-uri name version))
> +       (sha256
> +        (base32
> "19jpprryixi452jwhws3bbks6ki3wni9kgzah3srg22a3x8fsi8a"))))
> +    (build-system mix-build-system)
> +    (propagated-inputs (list elixir-nimble-parsec))
> +    (arguments
> +     (list
> +      #:tests? #f))
Why?
> +    (synopsis "Syntax highlighter for source code")
> +    (description
> +     "Makeup is a generic syntax highlighter in the style of
> Pygments suitable for use in code hosting,
> +forums, wikis or other applications that need to prettify source
> code.")
> +    (home-page "https://hexdocs.pm/makeup/")
> +    (license license:bsd-2)))
> +
>  ;;;
>  ;;; Avoid adding new packages to the end of this file. To reduce the
> chances
>  ;;; of a merge conflict, place them above by existing packages with
> similar
diff mbox series

Patch

diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-xyz.scm
index 352360fae..afc8b0db0 100644
--- a/gnu/packages/elixir-xyz.scm
+++ b/gnu/packages/elixir-xyz.scm
@@ -52,6 +52,28 @@  (define-public elixir-nimble-parsec
     (home-page "https://hexdocs.pm/nimble_parsec/")
     (license license:asl2.0)))
 
+(define-public elixir-makeup
+  (package
+    (name "elixir-makeup")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "19jpprryixi452jwhws3bbks6ki3wni9kgzah3srg22a3x8fsi8a"))))
+    (build-system mix-build-system)
+    (propagated-inputs (list elixir-nimble-parsec))
+    (arguments
+     (list
+      #:tests? #f))
+    (synopsis "Syntax highlighter for source code")
+    (description
+     "Makeup is a generic syntax highlighter in the style of Pygments suitable for use in code hosting,
+forums, wikis or other applications that need to prettify source code.")
+    (home-page "https://hexdocs.pm/makeup/")
+    (license license:bsd-2)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar