diff mbox series

[bug#66801,v3,10/15] gnu: Add elixir-castore.

Message ID d7a7c8d6953c7560606b07764538a771e731ddfd.1702044562.git.contact@phfrohring.com
State New
Headers show
Series [bug#66801,v3,01/15] build-system: Add mix-build-system. | expand

Commit Message

Pierre-Henry Fröhring Dec. 8, 2023, 3:03 p.m. UTC
From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>

* gnu/packages/elixir-xyz.scm (elixir-castore): New variable.

Change-Id: Iea1fea8241d19ff35a183af9c3fbf2ed5198a259
---
 gnu/packages/elixir-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Liliana Marie Prikler Dec. 8, 2023, 3:36 p.m. UTC | #1
Am Freitag, dem 08.12.2023 um 16:03 +0100 schrieb Pierre-Henry
Fröhring:
> From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>
> 
> * gnu/packages/elixir-xyz.scm (elixir-castore): New variable.
> 
> Change-Id: Iea1fea8241d19ff35a183af9c3fbf2ed5198a259
> ---
>  gnu/packages/elixir-xyz.scm | 20 ++++++++++++++++++++
>  1 file changed, 20 insertions(+)
> 
> diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-
> xyz.scm
> index 12aee0d78..f50c8f018 100644
> --- a/gnu/packages/elixir-xyz.scm
> +++ b/gnu/packages/elixir-xyz.scm
> @@ -167,6 +167,26 @@ (define-public elixir-inch-ex
>      (home-page "https://hex.pm/packages/inch_ex")
>      (license license:expat)))
>  
> +(define-public elixir-castore
> +  (package
> +    (name "elixir-castore")
> +    (version "1.0.4")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (hexpm-uri name version))
> +       (sha256
> +        (base32
> "1y44amb8falsmrfzpkmf7qp6215g9kdl76g91dpna4af2jwc264l"))))
> +    (build-system mix-build-system)
> +    ;; There is no test/ in the source.
> +    (arguments
> +     (list
> +      #:tests? #f))
Move the comment closer to the cause.
> +    (synopsis "Up-to-date CA certificate store")
> +    (description "Up-to-date CA certificate store.")
Make the description a full sentence.
> +    (home-page "https://hexdocs.pm/castore/")
> +    (license license:asl2.0)))
> +
>  ;;;
>  ;;; Avoid adding new packages to the end of this file. To reduce the
> chances
>  ;;; of a merge conflict, place them above by existing packages with
> similar
Find ways to avoid this :)
diff mbox series

Patch

diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-xyz.scm
index 12aee0d78..f50c8f018 100644
--- a/gnu/packages/elixir-xyz.scm
+++ b/gnu/packages/elixir-xyz.scm
@@ -167,6 +167,26 @@  (define-public elixir-inch-ex
     (home-page "https://hex.pm/packages/inch_ex")
     (license license:expat)))
 
+(define-public elixir-castore
+  (package
+    (name "elixir-castore")
+    (version "1.0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "1y44amb8falsmrfzpkmf7qp6215g9kdl76g91dpna4af2jwc264l"))))
+    (build-system mix-build-system)
+    ;; There is no test/ in the source.
+    (arguments
+     (list
+      #:tests? #f))
+    (synopsis "Up-to-date CA certificate store")
+    (description "Up-to-date CA certificate store.")
+    (home-page "https://hexdocs.pm/castore/")
+    (license license:asl2.0)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar