diff mbox series

[bug#66801,v3,07/15] gnu: Add elixir-file-system.

Message ID 3e47d3141e2e4b0dc0189ed755308aaf9932b867.1702044562.git.contact@phfrohring.com
State New
Headers show
Series [bug#66801,v3,01/15] build-system: Add mix-build-system. | expand

Commit Message

Pierre-Henry Fröhring Dec. 8, 2023, 3:03 p.m. UTC
From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>

* gnu/packages/elixir-xyz.scm (elixir-file-system): New variable.

Change-Id: I54e9c9069ddf150bb0c882775b0b2c9d5e59abd6
---
 gnu/packages/elixir-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Liliana Marie Prikler Dec. 8, 2023, 3:33 p.m. UTC | #1
Am Freitag, dem 08.12.2023 um 16:03 +0100 schrieb Pierre-Henry
Fröhring:
> From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>
> 
> * gnu/packages/elixir-xyz.scm (elixir-file-system): New variable.
> 
> Change-Id: I54e9c9069ddf150bb0c882775b0b2c9d5e59abd6
> ---
>  gnu/packages/elixir-xyz.scm | 27 +++++++++++++++++++++++++++
>  1 file changed, 27 insertions(+)
> 
> diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-
> xyz.scm
> index 544a414b4..bed84e9f2 100644
> --- a/gnu/packages/elixir-xyz.scm
> +++ b/gnu/packages/elixir-xyz.scm
> @@ -98,6 +98,33 @@ (define-public elixir-jason
>      (home-page "https://hexdocs.pm/jason/")
>      (license license:asl2.0)))
>  
> +(define-public elixir-file-system
> +  (package
> +    (name "elixir-file-system")
> +    (version "0.2.10")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (hexpm-uri name version))
> +       (sha256
> +        (base32
> "1p0myxmnjjds8bbg69dd6fvhk8q3n7lb78zd4qvmjajnzgdmw6a1"))))
> +    (build-system mix-build-system)
> +    (propagated-inputs (list inotify-tools))
By convention, arguments follow build-system, only thereafter come
inputs.
> +    (arguments
> +     (list
> +      #:tests? #f ;There is no test/ in the source.
> +      #:phases #~(modify-phases %standard-phases
> +                   (add-after 'unpack 'rm-priv
> +                     (lambda _
> +                       ;; This directory represents source code not
> needed on UNIX systems.
> +                       ;; Since we aim at UNIX systems, it is
> deleted.
> +                       (delete-file-recursively "priv"))))))
Is this bundled or non-free source?  If so, delete it in a snippet.
> +    (synopsis "File system change watcher")
> +    (description "Provides a file system change watcher wrapper
> based on
> +[fs](https://github.com/synrc/fs).")
> +    (home-page "https://hexdocs.pm/file_system/")
> +    (license license:wtfpl2)))
> +
Cheers
diff mbox series

Patch

diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-xyz.scm
index 544a414b4..bed84e9f2 100644
--- a/gnu/packages/elixir-xyz.scm
+++ b/gnu/packages/elixir-xyz.scm
@@ -98,6 +98,33 @@  (define-public elixir-jason
     (home-page "https://hexdocs.pm/jason/")
     (license license:asl2.0)))
 
+(define-public elixir-file-system
+  (package
+    (name "elixir-file-system")
+    (version "0.2.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "1p0myxmnjjds8bbg69dd6fvhk8q3n7lb78zd4qvmjajnzgdmw6a1"))))
+    (build-system mix-build-system)
+    (propagated-inputs (list inotify-tools))
+    (arguments
+     (list
+      #:tests? #f ;There is no test/ in the source.
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'unpack 'rm-priv
+                     (lambda _
+                       ;; This directory represents source code not needed on UNIX systems.
+                       ;; Since we aim at UNIX systems, it is deleted.
+                       (delete-file-recursively "priv"))))))
+    (synopsis "File system change watcher")
+    (description "Provides a file system change watcher wrapper based on
+[fs](https://github.com/synrc/fs).")
+    (home-page "https://hexdocs.pm/file_system/")
+    (license license:wtfpl2)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar