diff mbox series

[bug#66801,v3,06/15] gnu: Add elixir-jason.

Message ID 30b84fca7342449cde69ed948be7bcdfcc1127d1.1702044562.git.contact@phfrohring.com
State New
Headers show
Series [bug#66801,v3,01/15] build-system: Add mix-build-system. | expand

Commit Message

Pierre-Henry Fröhring Dec. 8, 2023, 3:03 p.m. UTC
From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>

* gnu/packages/elixir-xyz.scm (elixir-jason): New variable.

Change-Id: Iadd816e2b5db6d146728aacb4d6b2c66aba4304c
---
 gnu/packages/elixir-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Liliana Marie Prikler Dec. 8, 2023, 3:31 p.m. UTC | #1
Am Freitag, dem 08.12.2023 um 16:03 +0100 schrieb Pierre-Henry
Fröhring:
> From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>
> 
> * gnu/packages/elixir-xyz.scm (elixir-jason): New variable.
> 
> Change-Id: Iadd816e2b5db6d146728aacb4d6b2c66aba4304c
> ---
>  gnu/packages/elixir-xyz.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
> 
> diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-
> xyz.scm
> index afc8b0db0..544a414b4 100644
> --- a/gnu/packages/elixir-xyz.scm
> +++ b/gnu/packages/elixir-xyz.scm
> @@ -74,6 +74,30 @@ (define-public elixir-makeup
>      (home-page "https://hexdocs.pm/makeup/")
>      (license license:bsd-2)))
>  
> +(define-public elixir-jason
> +  (package
> +    (name "elixir-jason")
> +    (version "1.4.1")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (hexpm-uri name version))
> +       (sha256
> +        (base32
> "18d70i31bz11nr6vgsjn5prvhkvwqbyf3xq22ck5cnsnzp6ixc7v"))))
> +    (build-system mix-build-system)
> +    ;; There is no test/ in the source.
> +    (arguments
> +     (list
> +      #:tests? #f))
I'll move that comment closer to the cause.  Btw. you don't need to
split those lines if everything fits into one.
> +    (synopsis "JSON parser and generator")
> +    (description
> +     "Parser and generator are written in pure Elixir and optimized
> for speed. They
> +are at least twice as fast as other Elixir/Erlang libraries (e.g.
> +Poison). The performance is comparable to jiffy, which is
> implemented in C as
> +a NIF.")
> +    (home-page "https://hexdocs.pm/jason/")
> +    (license license:asl2.0)))
> +
Cheers
diff mbox series

Patch

diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-xyz.scm
index afc8b0db0..544a414b4 100644
--- a/gnu/packages/elixir-xyz.scm
+++ b/gnu/packages/elixir-xyz.scm
@@ -74,6 +74,30 @@  (define-public elixir-makeup
     (home-page "https://hexdocs.pm/makeup/")
     (license license:bsd-2)))
 
+(define-public elixir-jason
+  (package
+    (name "elixir-jason")
+    (version "1.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "18d70i31bz11nr6vgsjn5prvhkvwqbyf3xq22ck5cnsnzp6ixc7v"))))
+    (build-system mix-build-system)
+    ;; There is no test/ in the source.
+    (arguments
+     (list
+      #:tests? #f))
+    (synopsis "JSON parser and generator")
+    (description
+     "Parser and generator are written in pure Elixir and optimized for speed. They
+are at least twice as fast as other Elixir/Erlang libraries (e.g.
+Poison). The performance is comparable to jiffy, which is implemented in C as
+a NIF.")
+    (home-page "https://hexdocs.pm/jason/")
+    (license license:asl2.0)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar