diff mbox series

[bug#66801,v3,04/15] gnu: Add elixir-nimble-parsec.

Message ID 844f76d247df4d3a60e4f7923a476db61c53fd3b.1702044562.git.contact@phfrohring.com
State New
Headers show
Series [bug#66801,v3,01/15] build-system: Add mix-build-system. | expand

Commit Message

Pierre-Henry Fröhring Dec. 8, 2023, 3:03 p.m. UTC
From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>

* gnu/packages/elixir-xyz.scm (elixir-nimble-parsec): New variable.

Change-Id: I79bab8095aee3212bc295354ead55df49ef92d17
---
 gnu/packages/elixir-xyz.scm | 59 +++++++++++++++++++++++++++++++++++++
 1 file changed, 59 insertions(+)
 create mode 100644 gnu/packages/elixir-xyz.scm

Comments

Liliana Marie Prikler Dec. 8, 2023, 3:30 p.m. UTC | #1
Am Freitag, dem 08.12.2023 um 16:03 +0100 schrieb Pierre-Henry
Fröhring:
> From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>
> 
> * gnu/packages/elixir-xyz.scm (elixir-nimble-parsec): New variable.
> 
> Change-Id: I79bab8095aee3212bc295354ead55df49ef92d17
> ---
>  gnu/packages/elixir-xyz.scm | 59
> +++++++++++++++++++++++++++++++++++++
>  1 file changed, 59 insertions(+)
>  create mode 100644 gnu/packages/elixir-xyz.scm
> 
> diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-
> xyz.scm
> new file mode 100644
> index 000000000..352360fae
> --- /dev/null
> +++ b/gnu/packages/elixir-xyz.scm
> @@ -0,0 +1,59 @@
> +;;; GNU Guix --- Functional package management for GNU
> +;;; Copyright © 2023 Pierre-Henry Fröhring
> <phfrohring@deeplinks.com>
> +;;;
> +;;; This file is part of GNU Guix.
> +;;;
> +;;; GNU Guix is free software; you can redistribute it and/or modify
> it
> +;;; under the terms of the GNU General Public License as published
> by
> +;;; the Free Software Foundation; either version 3 of the License,
> or (at
> +;;; your option) any later version.
> +;;;
> +;;; GNU Guix is distributed in the hope that it will be useful, but
> +;;; WITHOUT ANY WARRANTY; without even the implied warranty of
> +;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
> +;;; GNU General Public License for more details.
> +;;;
> +;;; You should have received a copy of the GNU General Public
> License
> +;;; along with GNU Guix.  If not, see
> <http://www.gnu.org/licenses/>.
> +
> +(define-module (gnu packages elixir-xyz)
> +  #:use-module ((guix licenses) #:prefix license:)
> +  #:use-module (gnu packages elixir)
> +  #:use-module (gnu packages linux)
> +  #:use-module (gnu packages)
> +  #:use-module (guix build-system gnu)
> +  #:use-module (guix build-system mix)
> +  #:use-module (guix download)
> +  #:use-module (guix git-download)
> +  #:use-module (guix gexp)
> +  #:use-module (guix utils)
> +  #:use-module (guix packages)
> +  #:use-module (srfi srfi-1)
> +  #:use-module (srfi srfi-26))
> +
> +(define-public elixir-nimble-parsec
> +  (package
> +    (name "elixir-nimble-parsec")
> +    (version "1.3.1")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (hexpm-uri name version))
> +       (sha256
> +        (base32
> "0rxiw6jzz77v0j460wmzcprhdgn71g1hrz3mcc6djn7bnb0f70i6"))))
> +    (build-system mix-build-system)
> +    (arguments
> +     (list
> +      #:tests? #f))
Why?
> +    (synopsis "Text-based parser combinators")
> +    (description
> +     "This library provides primitives for efficient parser
> combinators, allowing
> +for higher-level combinators through composition.")
> +    (home-page "https://hexdocs.pm/nimble_parsec/")
> +    (license license:asl2.0)))
diff mbox series

Patch

diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-xyz.scm
new file mode 100644
index 000000000..352360fae
--- /dev/null
+++ b/gnu/packages/elixir-xyz.scm
@@ -0,0 +1,59 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Pierre-Henry Fröhring <phfrohring@deeplinks.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages elixir-xyz)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (gnu packages elixir)
+  #:use-module (gnu packages linux)
+  #:use-module (gnu packages)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix build-system mix)
+  #:use-module (guix download)
+  #:use-module (guix git-download)
+  #:use-module (guix gexp)
+  #:use-module (guix utils)
+  #:use-module (guix packages)
+  #:use-module (srfi srfi-1)
+  #:use-module (srfi srfi-26))
+
+(define-public elixir-nimble-parsec
+  (package
+    (name "elixir-nimble-parsec")
+    (version "1.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "0rxiw6jzz77v0j460wmzcprhdgn71g1hrz3mcc6djn7bnb0f70i6"))))
+    (build-system mix-build-system)
+    (arguments
+     (list
+      #:tests? #f))
+    (synopsis "Text-based parser combinators")
+    (description
+     "This library provides primitives for efficient parser combinators, allowing
+for higher-level combinators through composition.")
+    (home-page "https://hexdocs.pm/nimble_parsec/")
+    (license license:asl2.0)))
+
+;;;
+;;; Avoid adding new packages to the end of this file. To reduce the chances
+;;; of a merge conflict, place them above by existing packages with similar
+;;; functionality or similar names.
+;;;