diff mbox series

[bug#66801,v3,15/15] gnu: Add elixir-machete.

Message ID 0fcd231dac02a6d0ee99254c37d93d38ffbb5735.1702044562.git.contact@phfrohring.com
State New
Headers show
Series [bug#66801,v3,01/15] build-system: Add mix-build-system. | expand

Commit Message

Pierre-Henry Fröhring Dec. 8, 2023, 3:03 p.m. UTC
From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>

* gnu/packages/elixir-xyz.scm (elixir-machete): New variable.

Change-Id: I76e0fd78aeeaeaa94a297032b3b309846510c975
---
 gnu/packages/elixir-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Liliana Marie Prikler Dec. 8, 2023, 3:40 p.m. UTC | #1
Am Freitag, dem 08.12.2023 um 16:03 +0100 schrieb Pierre-Henry
Fröhring:
> From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>
> 
> * gnu/packages/elixir-xyz.scm (elixir-machete): New variable.
> 
> Change-Id: I76e0fd78aeeaeaa94a297032b3b309846510c975
> ---
>  gnu/packages/elixir-xyz.scm | 20 ++++++++++++++++++++
>  1 file changed, 20 insertions(+)
> 
> diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-
> xyz.scm
> index 70b752bc3..a1a29dfa0 100644
> --- a/gnu/packages/elixir-xyz.scm
> +++ b/gnu/packages/elixir-xyz.scm
> @@ -280,6 +280,26 @@ (define-public elixir-dialyxir
>      (home-page "https://hexdocs.pm/dialyxir/")
>      (license license:asl2.0)))
>  
> +(define-public elixir-machete
> +  (package
> +    (name "elixir-machete")
> +    (version "0.2.8")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (hexpm-uri name version))
> +       (sha256
> +        (base32
> "0952603bmqsf6v3ja99zpbnbx5d52i4xksjkfj3irl45ccq5pgq9"))))
> +    (build-system mix-build-system)
> +    (native-inputs (list elixir-credo elixir-dialyxir))
> +    (synopsis "Literate test matchers for ExUnit")
> +    (description
> +     "Machete provides ergonomic match operators that act as
> building blocks to let
> +you define test expectations that can match data against any
> combination of
> +literals, variables, or parametrically defined matchers.")
> +    (home-page "https://hexdocs.pm/machete/")
> +    (license license:expat)))
> +
>  ;;;
>  ;;; Avoid adding new packages to the end of this file. To reduce the
> chances
>  ;;; of a merge conflict, place them above by existing packages with
> similar
LGTM modulo placement.
Pierre-Henry Fröhring Dec. 8, 2023, 5:30 p.m. UTC | #2
Ok, the patches 4..15 have been corrected and will follow.
Liliana Marie Prikler Dec. 8, 2023, 6:01 p.m. UTC | #3
Am Freitag, dem 08.12.2023 um 18:30 +0100 schrieb Pierre-Henry
Fröhring:
> Ok, the patches 4..15 have been corrected and will follow.
Don't forget to increment the reroll-count when amending a commit. 
Also, 3/15 needs to be amended as well.

Btw. the canonical "no tests" comment appears to be "; no tests".

Cheers
Pierre-Henry Fröhring Dec. 8, 2023, 6:19 p.m. UTC | #4
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Don't forget to increment the reroll-count when amending a commit.
> Also, 3/15 needs to be amended as well.
>
> Btw. the canonical "no tests" comment appears to be "; no tests".

Ok, I hope the next batch will be good enough.
diff mbox series

Patch

diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-xyz.scm
index 70b752bc3..a1a29dfa0 100644
--- a/gnu/packages/elixir-xyz.scm
+++ b/gnu/packages/elixir-xyz.scm
@@ -280,6 +280,26 @@  (define-public elixir-dialyxir
     (home-page "https://hexdocs.pm/dialyxir/")
     (license license:asl2.0)))
 
+(define-public elixir-machete
+  (package
+    (name "elixir-machete")
+    (version "0.2.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "0952603bmqsf6v3ja99zpbnbx5d52i4xksjkfj3irl45ccq5pgq9"))))
+    (build-system mix-build-system)
+    (native-inputs (list elixir-credo elixir-dialyxir))
+    (synopsis "Literate test matchers for ExUnit")
+    (description
+     "Machete provides ergonomic match operators that act as building blocks to let
+you define test expectations that can match data against any combination of
+literals, variables, or parametrically defined matchers.")
+    (home-page "https://hexdocs.pm/machete/")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar