diff mbox series

[bug#66801,v3,11/15] gnu: Add elixir-excoveralls.

Message ID 3beb1d8ba84e59c927164aa1315429c70f6b1634.1702044562.git.contact@phfrohring.com
State New
Headers show
Series [bug#66801,v3,01/15] build-system: Add mix-build-system. | expand

Commit Message

Pierre-Henry Fröhring Dec. 8, 2023, 3:03 p.m. UTC
From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>

* gnu/packages/elixir-xyz.scm (elixir-excoveralls): New variable.

Change-Id: Ib271d8a7393e21178806df28ab892afe99757297
---
 gnu/packages/elixir-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Liliana Marie Prikler Dec. 8, 2023, 3:38 p.m. UTC | #1
Am Freitag, dem 08.12.2023 um 16:03 +0100 schrieb Pierre-Henry
Fröhring:
> From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>
> 
> * gnu/packages/elixir-xyz.scm (elixir-excoveralls): New variable.
> 
> Change-Id: Ib271d8a7393e21178806df28ab892afe99757297
> ---
>  gnu/packages/elixir-xyz.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)
> 
> diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-
> xyz.scm
> index f50c8f018..f6be8e88f 100644
> --- a/gnu/packages/elixir-xyz.scm
> +++ b/gnu/packages/elixir-xyz.scm
> @@ -187,6 +187,31 @@ (define-public elixir-castore
>      (home-page "https://hexdocs.pm/castore/")
>      (license license:asl2.0)))
>  
> +(define-public elixir-excoveralls
> +  (package
> +    (name "elixir-excoveralls")
> +    (version "0.18.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (hexpm-uri name version))
> +       (sha256
> +        (base32
> "02x69ll5scvraky0k5gacvnnmldv5k04kgk02x087d9w3y8vn28i"))))
> +    (build-system mix-build-system)
> +    (propagated-inputs (list elixir-castore elixir-jason))
> +    ;; No test/ folder.
> +    (arguments
> +     (list
> +      #:tests? #f))
Collapse and move, same as before :)
> +    (synopsis "Coverage report tool with coveralls.io integration")
> +    (description
> +     "Library that reports test coverage statistics, with the option
> to
> +post to coveralls.io service.
Make this a complete sentence.

>  It uses Erlang's cover to generate coverage
> +information, and posts the test coverage results to coveralls.io
> through the
> +JSON API.")
Fair enough.

> +    (home-page "https://hexdocs.pm/excoveralls/")
> +    (license license:expat)))
> +
>  ;;;
>  ;;; Avoid adding new packages to the end of this file. To reduce the
> chances
>  ;;; of a merge conflict, place them above by existing packages with
> similar
diff mbox series

Patch

diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-xyz.scm
index f50c8f018..f6be8e88f 100644
--- a/gnu/packages/elixir-xyz.scm
+++ b/gnu/packages/elixir-xyz.scm
@@ -187,6 +187,31 @@  (define-public elixir-castore
     (home-page "https://hexdocs.pm/castore/")
     (license license:asl2.0)))
 
+(define-public elixir-excoveralls
+  (package
+    (name "elixir-excoveralls")
+    (version "0.18.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "02x69ll5scvraky0k5gacvnnmldv5k04kgk02x087d9w3y8vn28i"))))
+    (build-system mix-build-system)
+    (propagated-inputs (list elixir-castore elixir-jason))
+    ;; No test/ folder.
+    (arguments
+     (list
+      #:tests? #f))
+    (synopsis "Coverage report tool with coveralls.io integration")
+    (description
+     "Library that reports test coverage statistics, with the option to
+post to coveralls.io service. It uses Erlang's cover to generate coverage
+information, and posts the test coverage results to coveralls.io through the
+JSON API.")
+    (home-page "https://hexdocs.pm/excoveralls/")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar