diff mbox series

[bug#66801,v3,09/15] gnu: Add elixir-inch-ex.

Message ID 3764f1dd233ecdaa464d8ff594be84dac171ed60.1702044562.git.contact@phfrohring.com
State New
Headers show
Series [bug#66801,v3,01/15] build-system: Add mix-build-system. | expand

Commit Message

Pierre-Henry Fröhring Dec. 8, 2023, 3:03 p.m. UTC
From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>

* gnu/packages/elixir-xyz.scm (elixir-inch-ex): New variable.

Change-Id: I6e98424528a0264a2587d28fcf065fa74eff0f1a
---
 gnu/packages/elixir-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Liliana Marie Prikler Dec. 8, 2023, 3:35 p.m. UTC | #1
Am Freitag, dem 08.12.2023 um 16:03 +0100 schrieb Pierre-Henry
Fröhring:
> From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>
> 
> * gnu/packages/elixir-xyz.scm (elixir-inch-ex): New variable.
> 
> Change-Id: I6e98424528a0264a2587d28fcf065fa74eff0f1a
> ---
>  gnu/packages/elixir-xyz.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)
> 
> diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-
> xyz.scm
> index 984649de4..12aee0d78 100644
> --- a/gnu/packages/elixir-xyz.scm
> +++ b/gnu/packages/elixir-xyz.scm
> @@ -144,6 +144,29 @@ (define-public elixir-bunt
>      (home-page "https://hexdocs.pm/bunt/")
>      (license license:expat)))
>  
> +(define-public elixir-inch-ex
> +  (package
> +    (name "elixir-inch-ex")
> +    (version "2.0.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (hexpm-uri name version))
> +       (sha256
> +        (base32
> "1a4rjcy3hn5pc40si1d1y7qg0b0mnxx6pw825la67ky8r9gfrl4n"))))
> +    (build-system mix-build-system)
> +    (arguments
> +     (list
> +      #:tests? #f))
> +    (propagated-inputs (list elixir-bunt elixir-jason))
> +    (synopsis
> +     "Offers a Mix task for suggestions on enhancing your inline
> documentation")
Perhaps shorten to "Suggest enhancements for inline documentation".
> +    (description
> +     "This package provides a Mix task that gives you hints where to
> improve your
> +inline docs.")
> +    (home-page "https://hex.pm/packages/inch_ex")
> +    (license license:expat)))
> +
>  ;;;
>  ;;; Avoid adding new packages to the end of this file. To reduce the
> chances
>  ;;; of a merge conflict, place them above by existing packages with
> similar
I see this line quite often now.  Perhaps you should at least sort your
new packages alphabetically so that it doesn't *always* show up?
diff mbox series

Patch

diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-xyz.scm
index 984649de4..12aee0d78 100644
--- a/gnu/packages/elixir-xyz.scm
+++ b/gnu/packages/elixir-xyz.scm
@@ -144,6 +144,29 @@  (define-public elixir-bunt
     (home-page "https://hexdocs.pm/bunt/")
     (license license:expat)))
 
+(define-public elixir-inch-ex
+  (package
+    (name "elixir-inch-ex")
+    (version "2.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "1a4rjcy3hn5pc40si1d1y7qg0b0mnxx6pw825la67ky8r9gfrl4n"))))
+    (build-system mix-build-system)
+    (arguments
+     (list
+      #:tests? #f))
+    (propagated-inputs (list elixir-bunt elixir-jason))
+    (synopsis
+     "Offers a Mix task for suggestions on enhancing your inline documentation")
+    (description
+     "This package provides a Mix task that gives you hints where to improve your
+inline docs.")
+    (home-page "https://hex.pm/packages/inch_ex")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar