diff mbox series

[bug#66801,v3,13/15] gnu: Add elixir-erlex.

Message ID 9565a3613f72aec9d954d771a374579352c4a126.1702044562.git.contact@phfrohring.com
State New
Headers show
Series [bug#66801,v3,01/15] build-system: Add mix-build-system. | expand

Commit Message

Pierre-Henry Fröhring Dec. 8, 2023, 3:03 p.m. UTC
From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>

* gnu/packages/elixir-xyz.scm (elixir-erlex): New variable.

Change-Id: Ia518ad5fd32d3f5942b20113e61e4ef7e7895ff3
---
 gnu/packages/elixir-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Liliana Marie Prikler Dec. 8, 2023, 3:39 p.m. UTC | #1
Am Freitag, dem 08.12.2023 um 16:03 +0100 schrieb Pierre-Henry
Fröhring:
> From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>
> 
> * gnu/packages/elixir-xyz.scm (elixir-erlex): New variable.
> 
> Change-Id: Ia518ad5fd32d3f5942b20113e61e4ef7e7895ff3
> ---
>  gnu/packages/elixir-xyz.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)
> 
> diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-
> xyz.scm
> index afacbd872..08107934a 100644
> --- a/gnu/packages/elixir-xyz.scm
> +++ b/gnu/packages/elixir-xyz.scm
> @@ -236,6 +236,29 @@ (define-public elixir-credo
>      (home-page "https://hexdocs.pm/credo/")
>      (license license:expat)))
>  
> +(define-public elixir-erlex
> +  (package
> +    (name "elixir-erlex")
> +    (version "0.2.6")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (hexpm-uri name version))
> +       (sha256
> +        (base32
> "0x8c1j62y748ldvlh46sxzv5514rpzm809vxn594vd7y25by5lif"))))
> +    (build-system mix-build-system)
> +    (arguments
> +     (list
> +      #:tests? #f))
> +    (synopsis
> +     "Convert Erlang style structs and error messages to equivalent
> Elixir")
> +    (description
> +     "Converted structs and error messages are useful for pretty
> printing things
> +like Dialyzer errors and Observer .state.
Should this dot be there?

>  NOTE: Because this code calls the
> +Elixir formatter, it requires Elixir 1.6+.")
Pretty sure that's useless information because we package the right
Elixir, right?
> +    (home-page "https://hexdocs.pm/erlex/")
> +    (license license:asl2.0)))
> +
>  ;;;
>  ;;; Avoid adding new packages to the end of this file. To reduce the
> chances
>  ;;; of a merge conflict, place them above by existing packages with
> similar
Cheers
diff mbox series

Patch

diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-xyz.scm
index afacbd872..08107934a 100644
--- a/gnu/packages/elixir-xyz.scm
+++ b/gnu/packages/elixir-xyz.scm
@@ -236,6 +236,29 @@  (define-public elixir-credo
     (home-page "https://hexdocs.pm/credo/")
     (license license:expat)))
 
+(define-public elixir-erlex
+  (package
+    (name "elixir-erlex")
+    (version "0.2.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "0x8c1j62y748ldvlh46sxzv5514rpzm809vxn594vd7y25by5lif"))))
+    (build-system mix-build-system)
+    (arguments
+     (list
+      #:tests? #f))
+    (synopsis
+     "Convert Erlang style structs and error messages to equivalent Elixir")
+    (description
+     "Converted structs and error messages are useful for pretty printing things
+like Dialyzer errors and Observer .state. NOTE: Because this code calls the
+Elixir formatter, it requires Elixir 1.6+.")
+    (home-page "https://hexdocs.pm/erlex/")
+    (license license:asl2.0)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar