diff mbox series

[bug#66801,v3,12/15] gnu: Add elixir-credo.

Message ID 670c3550e3741978c2c307e8e08a1c49eace8fb5.1702044562.git.contact@phfrohring.com
State New
Headers show
Series [bug#66801,v3,01/15] build-system: Add mix-build-system. | expand

Commit Message

Pierre-Henry Fröhring Dec. 8, 2023, 3:03 p.m. UTC
From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>

* gnu/packages/elixir-xyz.scm (elixir-credo): New variable.

Change-Id: I6df0d926e0fb96caa65d081892026b3495431c83
---
 gnu/packages/elixir-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Liliana Marie Prikler Dec. 8, 2023, 3:39 p.m. UTC | #1
Am Freitag, dem 08.12.2023 um 16:03 +0100 schrieb Pierre-Henry
Fröhring:
> From: Pierre-Henry Fröhring <phfrohring@deeplinks.com>
> 
> * gnu/packages/elixir-xyz.scm (elixir-credo): New variable.
> 
> Change-Id: I6df0d926e0fb96caa65d081892026b3495431c83
> ---
>  gnu/packages/elixir-xyz.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
> 
> diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-
> xyz.scm
> index f6be8e88f..afacbd872 100644
> --- a/gnu/packages/elixir-xyz.scm
> +++ b/gnu/packages/elixir-xyz.scm
> @@ -212,6 +212,30 @@ (define-public elixir-excoveralls
>      (home-page "https://hexdocs.pm/excoveralls/")
>      (license license:expat)))
>  
> +(define-public elixir-credo
> +  (package
> +    (name "elixir-credo")
> +    (version "1.7.1")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (hexpm-uri name version))
> +       (sha256
> +        (base32
> "18jqi9s9r1587njzdxycvmmbma30cay9iamni4f3ih54jmh1r1z9"))))
> +    (build-system mix-build-system)
> +    (arguments (list #:tests? #f))
Good, it's collapsed, but you're still missing the comment explaining
why :)
> +    (propagated-inputs (list elixir-bunt elixir-file-system elixir-
> jason))
> +    (native-inputs (list elixir-excoveralls elixir-inch-ex))
> +    (synopsis "Static code analysis tool")
> +    (description
> +     "Credo is a static code analysis tool for the Elixir language
> with a focus on
> +teaching and code consistency. Credo can show you refactoring
> opportunities in
> +your code, complex code fragments, warn you about common mistakes,
> show
> +inconsistencies in your naming scheme and - if needed - help you
> enforce a
> +desired coding style.")
> +    (home-page "https://hexdocs.pm/credo/")
> +    (license license:expat)))
> +
>  ;;;
>  ;;; Avoid adding new packages to the end of this file. To reduce the
> chances
>  ;;; of a merge conflict, place them above by existing packages with
> similar
Otherwise LGTM modulo placement.
diff mbox series

Patch

diff --git a/gnu/packages/elixir-xyz.scm b/gnu/packages/elixir-xyz.scm
index f6be8e88f..afacbd872 100644
--- a/gnu/packages/elixir-xyz.scm
+++ b/gnu/packages/elixir-xyz.scm
@@ -212,6 +212,30 @@  (define-public elixir-excoveralls
     (home-page "https://hexdocs.pm/excoveralls/")
     (license license:expat)))
 
+(define-public elixir-credo
+  (package
+    (name "elixir-credo")
+    (version "1.7.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hexpm-uri name version))
+       (sha256
+        (base32 "18jqi9s9r1587njzdxycvmmbma30cay9iamni4f3ih54jmh1r1z9"))))
+    (build-system mix-build-system)
+    (arguments (list #:tests? #f))
+    (propagated-inputs (list elixir-bunt elixir-file-system elixir-jason))
+    (native-inputs (list elixir-excoveralls elixir-inch-ex))
+    (synopsis "Static code analysis tool")
+    (description
+     "Credo is a static code analysis tool for the Elixir language with a focus on
+teaching and code consistency. Credo can show you refactoring opportunities in
+your code, complex code fragments, warn you about common mistakes, show
+inconsistencies in your naming scheme and - if needed - help you enforce a
+desired coding style.")
+    (home-page "https://hexdocs.pm/credo/")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar