diff mbox series

[bug#65077,06/13] gnu: Add go-github-com-felixge-fgprof

Message ID e65f57c4348bdc7dccb72549636e1ba0969419cf.1691218710.git.fries1234@protonmail.com
State New
Headers show
Series Add scc | expand

Commit Message

Fries Aug. 5, 2023, 7 a.m. UTC
* gnu/packages/golang.scm (go-github-com-felixge-fgprof): Add variable.
---
 gnu/packages/golang.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

\( Aug. 5, 2023, 9:18 a.m. UTC | #1
Fries via Guix-patches via <guix-patches@gnu.org> writes:
> +    (arguments
> +     '(#:import-path "github.com/felixge/fgprof"
> +       #:phases (modify-phases %standard-phases
> +                  ;; The tests fails randomly.
> +                  (delete 'check))))

#:TESTS? #F and LIST.

> +    (propagated-inputs
> +     `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
> +       ("go-github-com-google-pprof" ,go-github-com-google-pprof)))

LIST.

  -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9f5ef95b82..208b88d934 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2113,6 +2113,36 @@  (define-public go-github-com-dhowett-go-plist
 types.")
       (license license:giftware))))
 
+(define-public go-github-com-felixge-fgprof
+  (package
+    (name "go-github-com-felixge-fgprof")
+    (version "0.9.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/felixge/fgprof")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "03q3vnjd13r944y2qvfncs21lfkgmg0y8z14zz0xda1hz490wha3"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/felixge/fgprof"
+       #:phases (modify-phases %standard-phases
+                  ;; The tests fails randomly.
+                  (delete 'check))))
+    (propagated-inputs
+     `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
+       ("go-github-com-google-pprof" ,go-github-com-google-pprof)))
+    (home-page "https://github.com/felixge/fgprof")
+    (synopsis "The Full Go Profiler")
+    (description
+     "Fgprof is a sampling Go profiler that allows you to analyze On-CPU as well as
+@uref{https://www.brendangregg.com/offcpuanalysis.html,Off-CPU} (e.g. I/O) time
+together.")
+    (license license:expat)))
+
 (define-public go-github-com-google-pprof
   (package
     (name "go-github-com-google-pprof")