diff mbox series

[bug#65080,09/13] gnu: Add go-github-com-dbaggerman-cuba

Message ID 22a6d8487c02b254463b35ff32e8ca3106342dd0.1691218710.git.fries1234@protonmail.com
State New
Headers show
Series Add scc | expand

Commit Message

Fries Aug. 5, 2023, 7 a.m. UTC
* gnu/packages/golang.scm (go-github-com-dbaggerman-cuba): Add variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

\( Aug. 5, 2023, 9:22 a.m. UTC | #1
Fries via Guix-patches via <guix-patches@gnu.org> writes:
> +    (arguments
> +     '(#:import-path "github.com/dbaggerman/cuba"))

LIST.

> +    (propagated-inputs
> +     `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
> +       ("go-github-com-pkg-profile" ,go-github-com-pkg-profile)
> +       ("go-github-com-karrick-godirwalk" ,go-github-com-karrick-godirwalk)))

LIST again.

> +    (synopsis "Project Cuba")
> +    (description
> +     "Experiment in allowing workers to own the means of production.")

Heh.  Reluctantly, I have to suggest a more technical description :)

  -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 69700d50b1..fd138c1566 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2113,6 +2113,32 @@  (define-public go-github-com-dhowett-go-plist
 types.")
       (license license:giftware))))
 
+(define-public go-github-com-dbaggerman-cuba
+  (package
+    (name "go-github-com-dbaggerman-cuba")
+    (version "0.3.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/dbaggerman/cuba")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1sbria32fh2bzc8agnm9p5id5z15mrqj4fyxhnkq05bh2qjkrwc7"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/dbaggerman/cuba"))
+    (propagated-inputs
+     `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
+       ("go-github-com-pkg-profile" ,go-github-com-pkg-profile)
+       ("go-github-com-karrick-godirwalk" ,go-github-com-karrick-godirwalk)))
+    (home-page "https://github.com/dbaggerman/cuba")
+    (synopsis "Project Cuba")
+    (description
+     "Experiment in allowing workers to own the means of production.")
+    (license license:expat)))
+
 (define-public go-github-com-karrick-godirwalk
   (package
     (name "go-github-com-karrick-godirwalk")