diff mbox series

[bug#65084,11/13] gnu: Add go-github-com-modern-go-reflect2

Message ID 42c1c33a8df64c0fd1553e4a50b2e9d3f3b8d850.1691218710.git.fries1234@protonmail.com
State New
Headers show
Series Add scc | expand

Commit Message

Fries Aug. 5, 2023, 7 a.m. UTC
* gnu/packages/golang.scm (go-github-com-modern-go-reflect2): Add variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

\( Aug. 5, 2023, 9:24 a.m. UTC | #1
Fries via Guix-patches via <guix-patches@gnu.org> writes:
> +    (arguments
> +     '(#:import-path "github.com/modern-go/reflect2"))

LIST.

  -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 72dfc51507..9b38ed4daf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6773,6 +6773,29 @@  (define-public go-github-com-mitchellh-reflectwalk
 unknown structures such as those decoded from JSON.")
     (license license:expat)))
 
+(define-public go-github-com-modern-go-reflect2
+  (package
+    (name "go-github-com-modern-go-reflect2")
+    (version "1.0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/modern-go/reflect2")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "05a89f9j4nj8v1bchfkv2sy8piz746ikj831ilbp54g8dqhl8vzr"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/modern-go/reflect2"))
+    (home-page "https://github.com/modern-go/reflect2")
+    (synopsis "Cheaper reflect API")
+    (description
+     "This library provides a reflect api for Go programs
+without the runtime cost of the standard library reflect.Value.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-modern-go-concurrent
   (package
     (name "go-github-com-modern-go-concurrent")