diff mbox series

[bug#65078,05/13] gnu: Add go-github-com-google-pprof

Message ID 4a3feca209159af15daf812174ccc534f273f1f4.1691218710.git.fries1234@protonmail.com
State New
Headers show
Series Add scc | expand

Commit Message

Fries Aug. 5, 2023, 7 a.m. UTC
* gnu/packages/golang.scm (go-github-com-google-pprof): Add variable.
---
 gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

\( Aug. 5, 2023, 9:18 a.m. UTC | #1
Fries via Guix-patches via <guix-patches@gnu.org> writes:
> +    (arguments
> +     '(#:import-path "github.com/google/pprof"))

LIST etc.

> +    (propagated-inputs
> +     `(("go-golang-org-x-sys" ,go-golang-org-x-sys)
> +       ("go-github-com-ianlancetaylor-demangle" ,go-github-com-ianlancetaylor-demangle)
> +       ("go-github-com-chzyer-readline" ,go-github-com-chzyer-readline)))

LIST here too.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5df38a02e5..9f5ef95b82 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2113,6 +2113,34 @@  (define-public go-github-com-dhowett-go-plist
 types.")
       (license license:giftware))))
 
+(define-public go-github-com-google-pprof
+  (package
+    (name "go-github-com-google-pprof")
+    (version "0.0.0-20230728192033-2ba5b33183c6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/google/pprof")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1c5hh0b5cqlhm888lwlf713vv572562x56dpyijs9bzjdy5y54jg"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/google/pprof"))
+    (propagated-inputs
+     `(("go-golang-org-x-sys" ,go-golang-org-x-sys)
+       ("go-github-com-ianlancetaylor-demangle" ,go-github-com-ianlancetaylor-demangle)
+       ("go-github-com-chzyer-readline" ,go-github-com-chzyer-readline)))
+    (home-page "https://github.com/google/pprof")
+    (synopsis
+     "PProf is a tool for visualization and analysis of profiling data")
+    (description
+     "PProf is a tool for collection, manipulation and visualization of performance
+profiles.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-ianlancetaylor-demangle
   (package
     (name "go-github-com-ianlancetaylor-demangle")