diff mbox series

[bug#65083,13/13] gnu: Add scc

Message ID 31eb7dc018e2c47bd0c880291284e32cc2177ced.1691218710.git.fries1234@protonmail.com
State New
Headers show
Series Add scc | expand

Commit Message

Fries Aug. 5, 2023, 7:01 a.m. UTC
* gnu/packages/code.scm (scc): New variable.
---
 gnu/packages/code.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

\( Aug. 5, 2023, 9:26 a.m. UTC | #1
Fries via Guix-patches via <guix-patches@gnu.org> writes:
> +    (native-inputs (list go-github-com-dbaggerman-cuba
> +                         go-github-com-json-iterator-go
> +                         go-github-com-mattn-go-runewidth
> +                         go-github-com-minio-blake2b-simd
> +                         go-github-com-spf13-cobra
> +                         go-golang-org-x-text
> +                         go-gopkg-in-yaml-v2))

s/native-inputs/inputs/, except for the packages used in tests, if any.

> +    (arguments
> +     `(#:import-path "github.com/boyter/scc"))

LIST.

> +    (home-page "https://github.com/boyter/scc")
> +    (synopsis "Very fast accurate code counter written in pure Go")

Maybe:

  (synopsis "Fast code counter written in Go")

> +    (description
> +     "A tool similar to cloc, sloccount and tokei.
> +For counting the lines of code, blank lines, comment lines, and
> +physical lines of source code in many programming languages.
> +
> +Goal is to be the fastest code counter possible, but also
> +perform COCOMO calculation like sloccount and to estimate
> +code complexity similar to cyclomatic complexity calculators.")

  (description
   "@command{scc} provides a lines-of-code counter similar to tools like
@command{cloc} and @command{sloccount}.  It aims to be as fast as
possible while supporting @acronym{COCOMO,Constructive Cost Model}
calculation and estimation of code complexity.")
\( Aug. 5, 2023, 10:01 a.m. UTC | #2
"(" <paren@disroot.org> writes:
>   (description
>    "@command{scc} provides a lines-of-code counter similar to tools like
> @command{cloc} and @command{sloccount}.  It aims to be as fast as
> possible while 

Agh. Should be:

  (description
   "@command{scc} provides a lines-of-code counter similar to tools like
  @command{cloc} and @command{sloccount}.  It aims to be as fast as
  possible while supporting @acronym{COCOMO,Constructive Cost Model}
  calculation and code complexity estimation.")

  -- (
diff mbox series

Patch

diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 9cdda2b751..6a74d1a9ca 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -44,6 +44,7 @@  (define-module (gnu packages code)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system python)
   #:use-module (guix build-system trivial)
+  #:use-module (guix build-system go)
   #:use-module (gnu packages)
   #:use-module (gnu packages autogen)
   #:use-module (gnu packages autotools)
@@ -373,6 +374,41 @@  (define-public cloc
 cloc can handle a greater variety of programming languages.")
     (license license:gpl2+)))
 
+(define-public scc
+  (package
+    (name "scc")
+    (version "3.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/boyter/scc")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1rkkfg6jimlc2rkajk6ypd5v0m3zai25ga5idz2pmkmzakv82n21"))))
+    (build-system go-build-system)
+    (native-inputs (list go-github-com-dbaggerman-cuba
+                         go-github-com-json-iterator-go
+                         go-github-com-mattn-go-runewidth
+                         go-github-com-minio-blake2b-simd
+                         go-github-com-spf13-cobra
+                         go-golang-org-x-text
+                         go-gopkg-in-yaml-v2))
+    (arguments
+     `(#:import-path "github.com/boyter/scc"))
+    (home-page "https://github.com/boyter/scc")
+    (synopsis "Very fast accurate code counter written in pure Go")
+    (description
+     "A tool similar to cloc, sloccount and tokei.
+For counting the lines of code, blank lines, comment lines, and
+physical lines of source code in many programming languages.
+
+Goal is to be the fastest code counter possible, but also
+perform COCOMO calculation like sloccount and to estimate
+code complexity similar to cyclomatic complexity calculators.")
+    (license license:expat)))
+
 (define-public the-silver-searcher
   (package
     (name "the-silver-searcher")