diff mbox series

[bug#65079,07/13] gnu: Add go-github-com-pkg-profile

Message ID d5a16e184406bdc66ef16e85a5a78efe931b073d.1691218710.git.fries1234@protonmail.com
State New
Headers show
Series Add scc | expand

Commit Message

Fries Aug. 5, 2023, 7 a.m. UTC
* gnu/packages/golang.scm (go-github-com-pkg-profile): New variable.
---
 gnu/packages/golang.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

\( Aug. 5, 2023, 9:19 a.m. UTC | #1
Fries via Guix-patches via <guix-patches@gnu.org> writes:
> +    (build-system go-build-system)
> +    (arguments
> +     '(#:import-path "github.com/pkg/profile"

Use LIST and #~.

> +       #:phases (modify-phases %standard-phases
> +                  ;; profile drops a cpu.pprof file inside its source directory
> +                  ;; after tests which makes it unreproducable so we remove it.

s/unreproducable/unreproducible/

> +                  (add-after 'check 'delete-test-file
> +                    (lambda _
> +                      (delete-file "src/github.com/pkg/profile/cpu.pprof"))))))

You can make this neater like so:

  (add-after 'check 'delete-test-file
    (lambda* (#:key import-path #:allow-other-keys)
      (delete-file (string-append "src/" import-path "/cpu.pprof"))))

> +    (propagated-inputs `(("go-github-com-felixge-fgprof" ,go-github-com-felixge-fgprof)))

LIST here too.

  -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 208b88d934..daa811a5dc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2113,6 +2113,36 @@  (define-public go-github-com-dhowett-go-plist
 types.")
       (license license:giftware))))
 
+(define-public go-github-com-pkg-profile
+  (package
+    (name "go-github-com-pkg-profile")
+    (version "1.7.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/pkg/profile")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0ifr9gnycjwh7dbvsb5vgs9kzlr548cb4m45zvl8i8lgd3qhppy1"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/pkg/profile"
+       #:phases (modify-phases %standard-phases
+                  ;; profile drops a cpu.pprof file inside its source directory
+                  ;; after tests which makes it unreproducable so we remove it.
+                  (add-after 'check 'delete-test-file
+                    (lambda _
+                      (delete-file "src/github.com/pkg/profile/cpu.pprof"))))))
+    (propagated-inputs `(("go-github-com-felixge-fgprof" ,go-github-com-felixge-fgprof)))
+    (home-page "https://github.com/pkg/profile")
+    (synopsis "Simple profiling for Go")
+    (description
+     "Profile provides a simple way to manage runtime/pprof profiling of your
+Go application.")
+    (license license:bsd-2)))
+
 (define-public go-github-com-felixge-fgprof
   (package
     (name "go-github-com-felixge-fgprof")