diff mbox series

[bug#65072,02/13] gnu: Add go-github-com-chyzer-test

Message ID 2d73f9922ae784fa47cb820b73517262ae08f52f.1691218710.git.fries1234@protonmail.com
State New
Headers show
Series Add scc | expand

Commit Message

Fries Aug. 5, 2023, 7 a.m. UTC
* gnu/packages/golang.scm (go-github-com-chyzer-test): New variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

\( Aug. 5, 2023, 9:14 a.m. UTC | #1
Fries via Guix-patches via <guix-patches@gnu.org> writes:
> +    (arguments
> +     '(#:import-path "github.com/chzyer/test"
> +       #:phases
> +       ;; Tests relating to a in-memory disk fail due to a Segfault.
> +       (modify-phases %standard-phases
> +         (delete 'check))))

Same as before: use LIST, #~, and #:TESTS?.

> +    (propagated-inputs `(("go-github-com-chzyer-logex" ,go-github-com-chzyer-logex)))

Inputs are now written like this:

  (propagated-inputs
   (list go-github-com-chzyer-logex))

> +    (synopsis "Testing")
> +    (description "Testing library.")

Please provide a more thorough synopsis and description.

  -- (
Maxim Cournoyer Sept. 1, 2023, 12:08 p.m. UTC | #2
tags 65072 + moreinfo
quit

Hi Fries,

Thank you for your contribution.

Fries <fries1234@protonmail.com> writes:

> * gnu/packages/golang.scm (go-github-com-chyzer-test): New variable.
> ---
>  gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
>  1 file changed, 26 insertions(+)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index d99f76dc7d..ef82f0aa1b 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -2113,6 +2113,32 @@ (define-public go-github-com-dhowett-go-plist
>  types.")
>        (license license:giftware))))
>  
> +(define-public go-github-com-chzyer-test
> +  (package
> +    (name "go-github-com-chzyer-test")
> +    (version "1.0.0")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/chzyer/test")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "1axdlcnx2qjsn5wsr2pr1m0w0a8k4nk5kkrngh742fgh81vzzy8s"))))
> +    (build-system go-build-system)
> +    (arguments
> +     '(#:import-path "github.com/chzyer/test"
> +       #:phases
> +       ;; Tests relating to a in-memory disk fail due to a Segfault.
> +       (modify-phases %standard-phases
> +         (delete 'check))))

This should be minimally investigated, and ideally an issue created on
upstream issue tracker and an URL added next to the comment to track its
resolution, e.g:

;; Tests relating to a in-memory disk fail due to a segfault (see:
;; $URL).

Also taking the comments from parens into account, could you please send
a v2 to this same issue (65072@debbugs.gnu.org) ?
Sharlatan Hellseher April 6, 2024, 3:52 p.m. UTC | #3
Pushed as c28b319640..cf4f87986a to master by closing
<https://issues.guix.gnu.org/65074>.

--
Oleg
Sharlatan Hellseher April 6, 2024, 3:53 p.m. UTC | #4
Pushed as c28b319640..cf4f87986a to master by closing
<https://issues.guix.gnu.org/65074>.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d99f76dc7d..ef82f0aa1b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2113,6 +2113,32 @@  (define-public go-github-com-dhowett-go-plist
 types.")
       (license license:giftware))))
 
+(define-public go-github-com-chzyer-test
+  (package
+    (name "go-github-com-chzyer-test")
+    (version "1.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/chzyer/test")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1axdlcnx2qjsn5wsr2pr1m0w0a8k4nk5kkrngh742fgh81vzzy8s"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/chzyer/test"
+       #:phases
+       ;; Tests relating to a in-memory disk fail due to a Segfault.
+       (modify-phases %standard-phases
+         (delete 'check))))
+    (propagated-inputs `(("go-github-com-chzyer-logex" ,go-github-com-chzyer-logex)))
+    (home-page "https://github.com/chzyer/test")
+    (synopsis "Testing")
+    (description "Testing library.")
+    (license license:expat)))
+
 (define-public go-github-com-chzyer-logex
   (package
     (name "go-github-com-chzyer-logex")