diff mbox series

[bug#65085,12/13] gnu: Add go-github-com-json-iterator-go

Message ID 70ee9566b6562ea36a20f1ae2d6b79e3349f6e34.1691218710.git.fries1234@protonmail.com
State New
Headers show
Series Add scc | expand

Commit Message

Fries Aug. 5, 2023, 7:01 a.m. UTC
* gnu/packages/golang.scm (go-github-com-json-iterator-go): Add variable.
---
 gnu/packages/golang.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

\( Aug. 5, 2023, 9:25 a.m. UTC | #1
Fries via Guix-patches via <guix-patches@gnu.org> writes:
> +    (arguments
> +     '(#:import-path "github.com/json-iterator/go"))

LIST.

> +    (propagated-inputs
> +     `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
> +       ("go-github-com-modern-go-reflect2" ,go-github-com-modern-go-reflect2)
> +       ("go-github-com-modern-go-concurrent" ,go-github-com-modern-go-concurrent)
> +       ("go-github-com-google-gofuzz" ,go-github-com-google-gofuzz)
> +       ("go-github-com-davecgh-go-spew" ,go-github-com-davecgh-go-spew)))

LIST.

> +    (home-page "https://github.com/json-iterator/go")
> +    (synopsis "High-performance, 100% compatible drop-in replacement of encoding/json")

s/of/for/

> +    (description
> +     "Package jsoniter implements encoding and decoding of JSON as defined in

s/Package jsoniter/This package/

  -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9b38ed4daf..b08e7060fc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4386,6 +4386,39 @@  (define-public go-github-com-goccy-go-json
      "Fast JSON encoder/decoder compatible with encoding/json for Go.")
     (license license:expat)))
 
+(define-public go-github-com-json-iterator-go
+  (package
+    (name "go-github-com-json-iterator-go")
+    (version "1.1.12")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/json-iterator/go")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1c8f0hxm18wivx31bs615x3vxs2j3ba0v6vxchsjhldc8kl311bz"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/json-iterator/go"))
+    (propagated-inputs
+     `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
+       ("go-github-com-modern-go-reflect2" ,go-github-com-modern-go-reflect2)
+       ("go-github-com-modern-go-concurrent" ,go-github-com-modern-go-concurrent)
+       ("go-github-com-google-gofuzz" ,go-github-com-google-gofuzz)
+       ("go-github-com-davecgh-go-spew" ,go-github-com-davecgh-go-spew)))
+    (home-page "https://github.com/json-iterator/go")
+    (synopsis "High-performance, 100% compatible drop-in replacement of encoding/json")
+    (description
+     "Package jsoniter implements encoding and decoding of JSON as defined in
+@uref{https://rfc-editor.org/rfc/rfc4627.html,RFC 4627} and provides interfaces
+with identical syntax of standard lib encoding/json.  Converting from
+encoding/json to jsoniter is no more than replacing the package with jsoniter
+and variable type declarations (if any).  jsoniter interfaces gives 100%
+compatibility with code using standard lib.")
+    (license license:expat)))
+
 (define-public go-github-com-getsentry-raven-go
   (let ((commit "5c24d5110e0e198d9ae16f1f3465366085001d92")
         (revision "0"))