mbox series

[bug#65074,00/13] Add scc

Message ID cover.1691218710.git.fries1234@protonmail.com
Headers show
Series Add scc | expand

Message

Fries Aug. 5, 2023, 7 a.m. UTC
This patch series adds the scc command line tool which is a fast Go
based code counter can calculate the COCOMO cost estimation model for
your codebase and the complexity of your codebase.

I added the various go packages that scc depends on to the golang.scm
module and scc to code.scm.

Fries (13):
  gnu: Add go-github-com-chyzer-logex
  gnu: Add go-github-com-chyzer-test
  gnu: Add go-github-com-chyzer-readline
  gnu: Add go-github-com-ianlancetaylor-demangle
  gnu: Add go-github-com-google-pprof
  gnu: Add go-github-com-felixge-fgprof
  gnu: Add go-github-com-pkg-profile
  gnu: Add go-github-com-karrick-godirwalk
  gnu: Add go-github-com-dbaggerman-cuba
  gnu: Add go-github-com-modern-go-concurrent
  gnu: Add go-github-com-modern-go-reflect2
  gnu: Add go-github-com-json-iterator-go
  gnu: Add scc

 gnu/packages/code.scm                         |  36 ++
 gnu/packages/golang.scm                       | 320 ++++++++++++++++++
 ...go-github-com-chzyer-logex-fix-tests.patch |  28 ++
 3 files changed, 384 insertions(+)
 create mode 100644 gnu/packages/patches/go-github-com-chzyer-logex-fix-tests.patch


base-commit: 42ae42cf41e8f5e88422e30d801251a3427d7f3b

Comments

Sharlatan Hellseher April 6, 2024, 3:50 p.m. UTC | #1
Hi,

Thank you for the patches.

I've shift them into dedicated local golang-* modules and apply some
modifications.


- accepted-patches [13/13]
  - [X] [PATCH v2 01/13] gnu: Add go-github-com-chzyer-logex
    - Place to golang-xyz
    - Tests disabled, upstream informed
      - https://github.com/chzyer/logex/pull/7
      - https://github.com/chzyer/logex/issues/4
    - referred-in
      - [PATCH 00/29] Add miller. https://issues.guix.gnu.org/66603
  - [X] [PATCH v2 02/13] gnu: Add go-github-com-chzyer-test
    - Place to golang-check
    - Add links to issues
    - referred-in
      - [PATCH 00/29] Add miller. https://issues.guix.gnu.org/66603
  - [X] [PATCH v2 03/13] gnu: Add go-github-com-chzyer-readline
    - Place to golang-xyz
    - referred-in
      - [PATCH 00/29] Add miller. https://issues.guix.gnu.org/66603
  - [X] [PATCH v2 04/13] gnu: Add go-github-com-ianlancetaylor-demangle
    - Place to golang-xyz
    - Add issue on version tag or release
      https://github.com/ianlancetaylor/demangle/issues/21
    - referred-in
      - [PATCH 04/13] gnu: Add go-github-com-ianlancetaylor-demangle
        https://issues.guix.gnu.org/65073
      - [PATCH 00/29] Add miller. https://issues.guix.gnu.org/66603
  - [X] [PATCH v2 05/13] gnu: Add go-github-com-google-pprof
    - Place to golang-check, Add go-pprof build, as end-user program
    - Add all license, some code in third party may be unbundled when we have more Node packages
    - Extend description
    - Update to the latest commit
    - referred-in
      - [PATCH 00/29] Add miller. https://issues.guix.gnu.org/66603
  - [X] [PATCH v2 06/13] gnu: Add go-github-com-felixge-fgprof
    - Place to golang-check
    - Update to 0.9.4
    - Enable tests
    - referred-in
      - [PATCH 06/13] gnu: Add go-github-com-felixge-fgprof https://issues.guix.gnu.org/65077
      - [PATCH 00/29] Add miller. https://issues.guix.gnu.org/66603
  - [X] [PATCH v2 07/13] gnu: Add go-github-com-pkg-profile
    - Place to golang-check
    - Disable tests, issue is open https://github.com/pkg/profile/issues/68
    - referred-in
      - [PATCH 07/13] gnu: Add go-github-com-pkg-profile https://issues.guix.gnu.org/65079
      - [PATCH 00/29] Add miller. https://issues.guix.gnu.org/66603
  - [X] [PATCH v2 08/13] gnu: Add go-github-com-karrick-godirwalk
    - Place to golang-xyz
    - referred-in
      - [PATCH 08/13] gnu: Add go-github-com-karrick-godirwalk https://issues.guix.gnu.org/65082
  - [X] [PATCH v2 09/13] gnu: Add go-github-com-dbaggerman-cuba
    - Place to golang-xyz
    - Remove github.com/pkg/profile as it's indirect dependence
    - referred-in
      - [PATCH 09/13] gnu: Add go-github-com-dbaggerman-cuba https://issues.guix.gnu.org/65080
  - [X] [PATCH v2 10/13] gnu: Add go-github-com-modern-go-concurrent
    - Place to golang-xyz
    - Use available version tag 1.0.3
    - referred-in
      - [PATCH 00/47] gnu: Add go-github-com-prometheus-prometheus. https://issues.guix.gnu.org/54560
  - [X] [PATCH v2 11/13] gnu: Add go-github-com-modern-go-reflect2
    - Place to golang-xyz
    - referred-in
      - [PATCH 00/47] gnu: Add go-github-com-prometheus-prometheus.
        https://issues.guix.gnu.org/54560
      - [PATCH 11/13] gnu: Add go-github-com-modern-go-reflect2 https://issues.guix.gnu.org/65084
  - [X] [PATCH v2 12/13] gnu: Add go-github-com-json-iterator-go
    - referred-in
      - [PATCH 12/13] gnu: Add go-github-com-json-iterator-go https://issues.guix.gnu.org/65085
      - [PATCH 00/47] gnu: Add go-github-com-prometheus-prometheus. https://issues.guix.gnu.org/54560
  - [X] [PATCH v2 13/13] gnu: Add scc

Pushed as c28b319640..cf4f87986a to master.

--
Oleg