diff mbox series

[bug#65073,04/13] gnu: Add go-github-com-ianlancetaylor-demangle

Message ID 462388f546dbb543bbf044d2c12f5020e9d114c2.1691218710.git.fries1234@protonmail.com
State New
Headers show
Series Add scc | expand

Commit Message

Fries Aug. 5, 2023, 7 a.m. UTC
* gnu/packages/golang.scm (go-github-com-ianlancetaylor-demangle): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

\( Aug. 5, 2023, 9:16 a.m. UTC | #1
Fries via Guix-patches via <guix-patches@gnu.org> writes:
> +    (build-system go-build-system)
> +    (arguments
> +     '(#:import-path "github.com/ianlancetaylor/demangle"))

  LIST

> +    (home-page "https://github.com/ianlancetaylor/demangle")
> +    (synopsis "Symbol name demangler written in Go")
> +    (description
> +     "Package demangle defines functions that demangle GCC/LLVM C++ and Rust symbol

s/Package demangle/This package/

Go developers no know much of grammars.

  -- (
Sharlatan Hellseher April 6, 2024, 3:53 p.m. UTC | #2
Pushed as c28b319640..cf4f87986a to master by closing
<https://issues.guix.gnu.org/65074>.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1a6d64de23..5df38a02e5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2113,6 +2113,31 @@  (define-public go-github-com-dhowett-go-plist
 types.")
       (license license:giftware))))
 
+(define-public go-github-com-ianlancetaylor-demangle
+  (package
+    (name "go-github-com-ianlancetaylor-demangle")
+    (version "0.0.0-20230524184225-eabc099b10ab")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ianlancetaylor/demangle")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1pvlg1adp50hnw8dz7il473xb197ixirg26cy5hj3ngb4qlajwvc"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/ianlancetaylor/demangle"))
+    (home-page "https://github.com/ianlancetaylor/demangle")
+    (synopsis "Symbol name demangler written in Go")
+    (description
+     "Package demangle defines functions that demangle GCC/LLVM C++ and Rust symbol
+names.  This package recognizes names that were mangled according to the C++ ABI
+defined at https://codesourcery.com/cxx-abi/ and the Rust ABI defined at
+https://rust-lang.github.io/rfcs/2603-rust-symbol-name-mangling-v0.html.")
+    (license license:bsd-3)))
+
 (define-public go-github-com-chzyer-readline
   (package
     (name "go-github-com-chzyer-readline")