diff mbox series

[bug#69729,41/41] gnu: ocaml-lacaml: Remove dependency on lapack.

Message ID 20240311110750.16327-42-romain.garbage@inria.fr
State New
Headers show
Series Improve performance in lapack dependent packages. | expand

Commit Message

Romain GARBAGE March 11, 2024, 11:07 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-lacaml): Remove dependency on lapack.

Change-Id: If3100fc29088110705e13e9be97abb7739f2fcab
---
 gnu/packages/ocaml.scm | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0f4c351141..a45b2d3592 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8344,9 +8344,14 @@  (define-public ocaml-lacaml
     (properties '((tunable? . #t)))
     (build-system dune-build-system)
     (arguments
-     `(#:tests? #f)) ; No test target.
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'find-openblas
+                 (lambda* _
+                   (setenv "LACAML_LIBS" "-lopenblas"))))
+           #:tests? #f))                ; No test target.
     (native-inputs
-     (list openblas lapack ocaml-base ocaml-stdio))
+     (list openblas ocaml-base ocaml-stdio))
     (home-page "https://mmottl.github.io/lacaml/")
     (synopsis
      "OCaml-bindings to BLAS and LAPACK")