diff mbox series

[bug#69729,32/41] gnu: python-cvxopt: Remove dependency on lapack.

Message ID 20240311110750.16327-33-romain.garbage@inria.fr
State New
Headers show
Series Improve performance in lapack dependent packages. | expand

Commit Message

Romain GARBAGE March 11, 2024, 11:07 a.m. UTC
* gnu/packages/maths.scm (python-cvxopt): Remove dependency on lapack.

Change-Id: I2a28ecf1ab5ea7683d6b8adf72054d3f86892771
---
 gnu/packages/maths.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 5aa3c50fd2..c6d67a1bcb 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -401,6 +401,7 @@  (define-public python-cvxopt
          (add-after 'unpack 'find-libraries
            (lambda* (#:key inputs #:allow-other-keys)
              (setenv "CVXOPT_BLAS_LIB" "openblas")
+             (setenv "CVXOPT_LAPACK_LIB" "openblas")
              (setenv "CVXOPT_BUILD_FFTW" "1")
              (setenv "CVXOPT_BUILD_GLPK" "1")
              (setenv "CVXOPT_BUILD_GSL" "1")
@@ -409,7 +410,6 @@  (define-public python-cvxopt
      (list fftw
            glpk
            gsl
-           lapack
            openblas
            suitesparse))
     (home-page "https://www.cvxopt.org")