diff mbox series

[bug#69729,12/41] gnu: ghc-hmatrix: Switch to openblas.

Message ID 20240311110750.16327-13-romain.garbage@inria.fr
State New
Headers show
Series Improve performance in lapack dependent packages. | expand

Commit Message

Romain GARBAGE March 11, 2024, 11:06 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-hmatrix): Switch input dependency from
lapack to openblas. Add configure flags.

Change-Id: Ic8924b1fb9fa61af16abd1ac2a22c82a352a8e1b
---
 gnu/packages/haskell-xyz.scm | 9 +++------
 1 file changed, 3 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 5d9e5757a0..b5943f2f47 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -5325,18 +5325,15 @@  (define-public ghc-hmatrix
     (build-system haskell-build-system)
     (properties '((upstream-name . "hmatrix")))
     (arguments
-     `(#:extra-directories ("lapack")))
+     `(#:configure-flags '("--flags=openblas")
+       #:extra-directories ("openblas")))
     (inputs
      (list ghc-random
            ghc-split
            ghc-storable-complex
            ghc-semigroups
            ghc-vector
-           ;;("openblas" ,openblas)
-           lapack))
-    ;; Guix's OpenBLAS is built with the flag "NO_LAPACK=1" which
-    ;; disables inclusion of the LAPACK functions.
-    ;; (arguments `(#:configure-flags '("--flags=openblas")))
+           openblas))
     (home-page "https://github.com/albertoruiz/hmatrix")
     (synopsis "Haskell numeric linear algebra library")
     (description "The HMatrix package provices a Haskell library for