diff mbox series

[bug#69729,37/41] gnu: libflame: Switch to openblas.

Message ID 20240311110750.16327-38-romain.garbage@inria.fr
State New
Headers show
Series Improve performance in lapack dependent packages. | expand

Commit Message

Romain GARBAGE March 11, 2024, 11:07 a.m. UTC
* gnu/packages/maths.scm (libflame): Switch input dependency from
lapack to openblas.

Change-Id: I7abdb8d126856488b0722b73c336309bf5c2234d
---
 gnu/packages/maths.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c6d67a1bcb..3d955e7e18 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2763,9 +2763,9 @@  (define-public libflame
                    (lambda* (#:key tests? #:allow-other-keys)
                      (substitute* "test/Makefile"
                        (("LIBBLAS .*")
-                        "LIBBLAS = -lblas\n")
+                        "LIBBLAS = -lopenblas\n")
                        (("LIBLAPACK .*")
-                        "LIBLAPACK = -llapack\n"))
+                        "LIBLAPACK = -lopenblas\n"))
                      (when tests?
                        (with-directory-excursion "test"
                          (mkdir "obj")
@@ -2784,7 +2784,7 @@  (define-public libflame
                                                     "/include/FLAME.h")
                                      (string-append static "/include"))))))))
       (inputs (list gfortran))
-      (native-inputs (list lapack perl python-wrapper))
+      (native-inputs (list openblas perl python-wrapper))
       (synopsis "High-performance library for @acronym{DLA, dense linear algebra} computations")
       (description "@code{libflame} is a portable library for dense matrix
 computations, providing much of the functionality present in LAPACK, developed