diff mbox series

[bug#69729,19/41] gnu: plink-ng: Remove lapack dep.

Message ID 20240311110750.16327-20-romain.garbage@inria.fr
State New
Headers show
Series Improve performance in lapack dependent packages. | expand

Commit Message

Romain GARBAGE March 11, 2024, 11:07 a.m. UTC
* gnu/packages/bioinformatics.scm (plink-ng): Remove dependency to lapack.

Change-Id: I4d14789c42dc216244872d70120efeeb97127a62
---
 gnu/packages/bioinformatics.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8b2fe2d017..6c2dc95fa6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9650,7 +9650,7 @@  (define-public plink-ng
      (list
       #:tests? #false ;TEST_EXTRACT_CHR doesn't produce expected files
       #:make-flags
-      #~(list "BLASFLAGS=-llapack -lopenblas"
+      #~(list "BLASFLAGS=-lopenblas"
               "NO_SSE42=1"
               "NO_AVX2=1"
               "STATIC_ZSTD="
@@ -9677,7 +9677,7 @@  (define-public plink-ng
                            (string-append
                             (assoc-ref outputs "out") "/bin")))))))
     (inputs
-     (list lapack openblas zlib `(,zstd "lib")))
+     (list openblas zlib `(,zstd "lib")))
     (native-inputs
      (list diffutils plink python simde)) ; for tests
     (home-page "https://www.cog-genomics.org/plink/")