diff mbox series

[bug#69729,30/41] gnu: proteinortho: Remove dependency on lapack.

Message ID 20240311110750.16327-31-romain.garbage@inria.fr
State New
Headers show
Series Improve performance in lapack dependent packages. | expand

Commit Message

Romain GARBAGE March 11, 2024, 11:07 a.m. UTC
* gnu/packages/bioinformatics.scm (proteinortho): Remove dependency on lapack.
---
 gnu/packages/bioinformatics.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ac2f7c1ade..98bc05d154 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8673,7 +8673,9 @@  (define-public proteinortho
              (substitute* "Makefile"
                (("INSTALLDIR=.*")
                 (string-append
-                 "INSTALLDIR=" (assoc-ref outputs "out") "/bin\n")))
+                 "INSTALLDIR=" (assoc-ref outputs "out") "/bin\n"))
+               (("-llapack -lblas")
+                "-lopenblas"))
              #t))
          (add-before 'install 'make-install-directory
            ;; The install directory is not created during 'make install'.
@@ -8697,7 +8699,6 @@  (define-public proteinortho
        ("perl" ,perl)
        ("python" ,python-wrapper)
        ("blast+" ,blast+)
-       ("lapack" ,lapack)
        ("openblas" ,openblas)))
     (native-inputs
      (list which))