diff mbox series

[bug#69729,22/41] gnu: superlu-dist: Remove dependency on lapack.

Message ID 20240311110750.16327-23-romain.garbage@inria.fr
State New
Headers show
Series Improve performance in lapack dependent packages. | expand

Commit Message

Romain GARBAGE March 11, 2024, 11:07 a.m. UTC
* gnu/packages/maths.scm (superlu-dist): Remove dependency on lapack.

Change-Id: I5893e16f7ef6fd688fd6b53eba6d3005b832f0ef
---
 gnu/packages/maths.scm | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c14dede5e0..2b2252746e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4443,7 +4443,6 @@  (define-public superlu-dist
     (inputs
      `(("gfortran" ,gfortran)
        ("blas" ,openblas)
-       ("lapack" ,lapack)
        ("combblas" ,combinatorial-blas)))
     (propagated-inputs
      `(("mpi" ,openmpi)                 ;headers include MPI heades
@@ -4454,7 +4453,7 @@  (define-public superlu-dist
        #:configure-flags (list "-DBUILD_SHARED_LIBS:BOOL=YES"
                                "-DTPL_ENABLE_COMBBLASLIB=YES"
                                "-DTPL_BLAS_LIBRARIES=-lopenblas"
-                               "-DTPL_LAPACK_LIBRARIES=-llapack"
+                               "-DTPL_LAPACK_LIBRARIES=-lopenblas"
                                (string-append "-DTPL_PARMETIS_LIBRARIES="
                                               (string-join
                                                '("ptscotchparmetis" "ptscotch" "ptscotcherr"