diff mbox series

[bug#69729,14/41] gnu: ipopt: Switch to openblas.

Message ID 20240311110750.16327-15-romain.garbage@inria.fr
State New
Headers show
Series Improve performance in lapack dependent packages. | expand

Commit Message

Romain GARBAGE March 11, 2024, 11:06 a.m. UTC
* gnu/packages/maths.scm (ipopt): Switch input dependency from
lapack to openblas and add required configure flags.

Change-Id: I58b84f0741a973adf81da1716e2e2659af1c50c4
---
 gnu/packages/maths.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d38dac267f..916dcde2c1 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2399,7 +2399,8 @@  (define-public ipopt
                 "08gznhwhqv1x4baksz350ih8q16r5rd0k8vals6078m3h94khr4b"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (modify-phases %standard-phases
+     '(#:configure-flags (list "--with-lapack=-lopenblas")
+       #:phases (modify-phases %standard-phases
                   (add-after 'install 'add--L-flags-in-ipopt.pc
                     (lambda* (#:key inputs outputs #:allow-other-keys)
                       ;; The '.pc' file lists '-llapack -lblas' in "Libs";
@@ -2412,14 +2413,14 @@  (define-public ipopt
                           (("Libs: (.*)-llapack -lblas(.*)$" _ before after)
                            (string-append "Libs: " before " " after "\n"
                                           "Libs.private: " before
-                                          "-L" lapack "/lib -llapack -lblas "
+                                          "-L" openblas "/lib -lopenblas"
                                           after "\n")))
                         #t))))))
     (native-inputs
      (list gfortran pkg-config))
     (inputs
      ;; TODO: Maybe add dependency on COIN-MUMPS, ASL, and HSL.
-     (list lapack))                    ;for both libblas and liblapack
+     (list openblas))                    ;for both libblas and liblapack
     (home-page "https://www.coin-or.org")
     (synopsis "Large-scale nonlinear optimizer")
     (description