diff mbox series

[bug#69729,34/41] gnu: grass: Remove dependency on lapack.

Message ID 20240311110750.16327-35-romain.garbage@inria.fr
State New
Headers show
Series Improve performance in lapack dependent packages. | expand

Commit Message

Romain GARBAGE March 11, 2024, 11:07 a.m. UTC
* gnu/packages/geo.scm (grass): Remove dependency on lapack.
Add 'fix-lapack build phase.

Change-Id: I758a9b2434f0ad9f8b85a5c5cde6d0a80e6defb2
---
 gnu/packages/geo.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 687effcace..6d3162b10d 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2610,7 +2610,6 @@  (define-public grass
          ("gdal" ,gdal)
          ("geos" ,geos)
          ("glu" ,glu)
-         ("lapack" ,lapack)
          ("libpng" ,libpng)
          ("libtiff" ,libtiff)
          ("mesa" ,mesa)
@@ -2644,6 +2643,11 @@  (define-public grass
                              (guix build python-build-system))
          #:phases
          (modify-phases %standard-phases
+           (add-after 'unpack 'fix-lapack
+             (lambda _
+               (substitute* "./configure"
+                 (("-lblas") "-lopenblas")
+                 (("-llapack") "-lopenblas"))))
            (replace 'configure
              (lambda* (#:key inputs outputs #:allow-other-keys)
                (let ((shell (search-input-file inputs "/bin/bash")))