mbox series

[bug#42180,00/22] Add extracting download, importer for hex.pm and rebar3 build-system for Erlang

Message ID cover.1593797694.git.h.goebel@crazy-compilers.com
Headers show
Series Add extracting download, importer for hex.pm and rebar3 build-system for Erlang | expand

Message

Hartmut Goebel July 3, 2020, 5:40 p.m. UTC
This adds

* "extracting download", which is meant to be used for package repositories
  where the actual source archive is packed into another archive, eventually
  carrying meta-data.  Using this derivation saves both storing the outer
  archive and extracting the actual one at build time.  The hash is calculated
  on the actual archive to ease validating the stored file.

  This currently is used be the hex.pm impoter (see below). But I've been
  told, this could be usefull for ruby, too.

* importer for hex.pm, a repository for Erlang and Elixir

* rebar3 build-system for Erlang

* Required modules

Hartmut Goebel (22):
  guix: Add extracting-download.
  guix: Add importer for hex.pm.
  guix: Add rebar3 build-system.
  gnu: Add erlang-cf.
  gnu: Add erlang-certifi.
  gnu: Add erlang-erlware-commons.
  gnu: Add erlang-cth-readable.
  gnu: Add erlang-bbmustache.
  gnu: Add erlang-getopt.
  gnu: Add erlang-eunit-formatters.
  gnu: Add erlang-providers.
  gnu: Add erlang-parse-trans.
  gnu: Add erlang-hex-core.
  gnu: Add erlang-ssl-verify-fun.
  gnu: Add erlang-relx.
  gnu: Add rebar3.
  gnu: Add erlang-edown.
  gnu: Add erlang-jsone.
  gnu: Add erlang-proper.
  gnu: Add erlang-rebar3-raw-deps.
  gnu: Add erlang-rebar3-git-vsn.
  gnu: Add erlang-rebar3-proper.

 Makefile.am                        |   6 +
 gnu/packages/erlang.scm            | 458 +++++++++++++++++++++++++++++
 guix/build-system/rebar3.scm       | 144 +++++++++
 guix/build/rebar3-build-system.scm | 155 ++++++++++
 guix/extracting-download.scm       | 172 +++++++++++
 guix/hexpm-download.scm            |  73 +++++
 guix/import/hexpm.scm              | 299 +++++++++++++++++++
 guix/import/utils.scm              |   1 +
 guix/scripts/import.scm            |   2 +-
 guix/scripts/import/hexpm.scm      | 114 +++++++
 guix/upstream.scm                  |  20 +-
 11 files changed, 1442 insertions(+), 2 deletions(-)
 create mode 100644 guix/build-system/rebar3.scm
 create mode 100644 guix/build/rebar3-build-system.scm
 create mode 100644 guix/extracting-download.scm
 create mode 100644 guix/hexpm-download.scm
 create mode 100644 guix/import/hexpm.scm
 create mode 100644 guix/scripts/import/hexpm.scm

Comments

Hartmut Goebel Jan. 22, 2021, 8:20 p.m. UTC | #1
Just for info: This is stale, since I have no time continuing the work.
It's still on my list.