diff mbox series

[bug#42180,06/22] gnu: Add erlang-erlware-commons.

Message ID 4aaa4bf292e0de63cd1bb80bf7d1605701189a07.1593797694.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add extracting download, importer for hex.pm and rebar3 build-system for Erlang | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Hartmut Goebel July 3, 2020, 5:43 p.m. UTC
* gnu/packages/erlang.scm (erlang-erlware-commons): New variable.
---
 gnu/packages/erlang.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index e55cca7cc6..ee5c61dea8 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -275,3 +275,24 @@  Mozilla's canonical set.")
     (description "This package provides a helper library for termial colour
 printing extending the io:format syntax to add colours.")
     (license license:expat)))
+
+(define-public erlang-erlware-commons
+  (package
+    (name "erlang-erlware-commons")
+    (version "1.3.1")
+    (source
+     (origin
+       (method hexpm-fetch)
+       (uri (hexpm-uri "erlware_commons" version))
+       (sha256
+        (base32 "1cs00ac71bjik8xq82caj19r3ik7zhbh579g74liyxdvbmxqk6i6"))))
+    (build-system rebar3-build-system)
+    (propagated-inputs
+     `(("erlang-cf" ,erlang-cf)))
+    (arguments
+     `(#:tests? #f)) ;; TODO: 1/219 tests fail -  very simple one, though
+    (home-page "http://erlware.github.io/erlware_commons/")
+    (synopsis "Additional standard library for Erlang")
+    (description "Erlware Commons is an Erlware project focused on all aspects
+of reusable Erlang components.")
+    (license license:expat)))