diff mbox series

[bug#42180,21/22] gnu: Add erlang-rebar3-git-vsn.

Message ID 2346f27bcc6cc3eeb72a0b9687f9b027b4eb57fe.1593797694.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add extracting download, importer for hex.pm and rebar3 build-system for Erlang | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Hartmut Goebel July 3, 2020, 5:43 p.m. UTC
* gnu/packages/erlang.scm (erlang-rebar3-git-vsn): New variable.
---
 gnu/packages/erlang.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 9c267250a0..e927f5db11 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -37,6 +37,7 @@ 
   #:use-module (gnu packages gl)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages version-control)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages wxwidgets))
 
@@ -503,6 +504,35 @@  testing of stateful systems.")
     (description "This package provides an Erlang providers library.")
     (license license:asl2.0)))
 
+(define-public erlang-rebar3-git-vsn
+  (package
+    (name "erlang-rebar3-git-vsn")
+    (version "1.1.1")
+    (source
+      (origin
+        (method hexpm-fetch)
+        (uri (hexpm-uri "rebar3_git_vsn" version))
+        (sha256
+          (base32 "1ra4xjyc40r97aqb8aq2rll1v8wkf9jyisnbk34xdqcgv9s9iw7d"))))
+    (build-system rebar3-build-system)
+    (inputs
+     `(("git" ,git)))
+    (arguments
+     `(#:tests? #f ;; depends on rebar TODO: remove this dependency
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((git (assoc-ref inputs "git")))
+               (substitute* "src/rebar3_git_vsn.erl"
+                 (("rebar_utils:sh\\(\"git " _)
+                  (string-append "rebar_utils:sh(\"" git "/bin/git ")))))))))
+    (home-page "https://github.com/soranoba/rebar3_git_vsn")
+    (synopsis "rebar3 plugin for generating the version from git")
+    (description "This plugin adds support for generating the version from
+git.")
+    (license license:expat)))
+
 (define-public erlang-rebar3-raw-deps
   (package
     (name "erlang-rebar3-raw-deps")