diff mbox series

[bug#42180,10/22] gnu: Add erlang-eunit-formatters.

Message ID b41a6a84c521af485373e7baade184c385901c76.1593797694.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Add extracting download, importer for hex.pm and rebar3 build-system for Erlang | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Hartmut Goebel July 3, 2020, 5:43 p.m. UTC
* gnu/packages/erlang.scm (erlang-eunit-formatters): New variable.
---
 gnu/packages/erlang.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index fcdafe6231..cb6c2b903e 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -353,6 +353,22 @@  outputs you want to be readable around all that noise they contain.")
 of reusable Erlang components.")
     (license license:expat)))
 
+(define-public erlang-eunit-formatters
+  (package
+    (name "erlang-eunit-formatters")
+    (version "0.5.0")
+    (source
+     (origin
+       (method hexpm-fetch)
+       (uri (hexpm-uri "eunit_formatters" version))
+       (sha256
+        (base32 "18q3vb12799584kdb998298b6bfh686mzi5s7pkb7djrf93vgf5f"))))
+    (build-system rebar3-build-system)
+    (home-page "https://github.com/seancribbs/eunit_formatters")
+    (synopsis "Better output for eunit suites")
+    (description "This package provides a better output for Erlang eunits.")
+    (license license:asl2.0)))
+
 (define-public erlang-getopt
   (package
     (name "erlang-getopt")